bringing a 86 pup back from the dead


jackass#1
03-26-2006, 06:01 PM
hi im new to the isuzu world but have beed on the s10 and blazer pages for awhile now. heres the deal, i was given a 86 2.3 pup 4x4. it had a blown head gasket. i replaced the gasket. gave a good tune up and cleaned carb(the right way). replaced fuel filter, bloew out fuel lines, and drained tank.
the problem im having is when i got it the fuel lines were not hooked up to the fuel pump. there are 4 branches coming off this pump(mechanical). i guessed putting them on. tried to start truck, great spark no fuel. i poured alittle gas into carb all it did was spit at me hard. it spit and smoked. need to know how the fuel lines go. i know there is a in, a out and a return, but what is the fourth one for? its on the very top of pump and is bent at a 90 deg pointing downward. to veiw the pump go to napa online and type in napa part number M70308and youll see what im talking about.
also why would it spit at me? what causes a carb to spit like that?

amigo-2k
03-26-2006, 07:41 PM
try posting here:


http://www.4x4wire.com/forums/postlist.php?Cat=&Board=UBB86

jackass#1
03-26-2006, 08:04 PM
great forum. thanks.

jackass#1
03-28-2006, 06:56 PM
found the problem. i marked everything so that everything would line backup on reassembly. wee i forgot i had to turn the pistons because after a few years of seating rust locked her up abit. so instead of #1 being at tdc is on the exhaust rotation. so i have to turn the pistons one full turn (without the valves moving). can i undo the timming belt to do this or do i have to do a total teardown again?
also the fuel pump issue was answered as well. the branch on top of pump is a drain for oil or fuel when the seal failes. does not get hooked to aline.
thanks for the help and i will let you all know how it turns out.

Add your comment to this topic!