94 Jimmy-Won't start, everything else is fine!


SammyJo13
02-22-2006, 08:43 AM
Bout 4 months ago, I turned into my driveway and my brakes froze up completely.My husband and dad are DIYers, so they started w/ the idle intake. Replaced that, the spark plugs and wires, distributor cap and rotor, fuel pump, filter, battery, and starter. Brakes are fine, but started to rough idle. Broke down and took it to a shop. Put it on a computer, and they told me that MY computer was fried. Replaced it. Still have problems. Read EGR valves are a prob. I'm in Louisiana--no emissions testing---so we unplugged it. Ran great for a long time, then no start. Has been freezing for the last few weeks, and truck doesn't want to start. Have cleaned EVERYTHING! Under the hood looks like a showtruck! Please help! Any input is fantastic at this point. Thanks from La.

rlith
02-22-2006, 05:06 PM
Bout 4 months ago, I turned into my driveway and my brakes froze up completely.My husband and dad are DIYers, so they started w/ the idle intake. Replaced that, the spark plugs and wires, distributor cap and rotor, fuel pump, filter, battery, and starter. Brakes are fine, but started to rough idle. Broke down and took it to a shop. Put it on a computer, and they told me that MY computer was fried. Replaced it. Still have problems. Read EGR valves are a prob. I'm in Louisiana--no emissions testing---so we unplugged it. Ran great for a long time, then no start. Has been freezing for the last few weeks, and truck doesn't want to start. Have cleaned EVERYTHING! Under the hood looks like a showtruck! Please help! Any input is fantastic at this point. Thanks from La.

Have you pulled the upper plenum to check for washing? Have you tested fuel pressure? Get a new egr back on there or pull your existing one and clean it. The EGR is needed, it's not there for nothing. An improperly working EGR can cause a lot of problems. Are you actually getting spark or just assuming?

SammyJo13
02-23-2006, 08:15 AM
Checked the plenum---all is fine. Checking the fuel pressure this afternoon---someone suggested a new pulsator, possibly. Heard that Tomaco EGRs are really good. Getting sparks for sure. Jumps off just fine. Thanks for the input!

Add your comment to this topic!