Check engine light/ throttle body


citygear
02-16-2006, 09:52 AM
I have a 2001 9-5 Aero which went into limp mode with tcs off and check
engine light on. I got off the road and got the car to run by disconnecting
battery and reseting computer. I had my mechanic check codes and 1290
came up. Throttle spring tension. I clean and checked spring and throttle
body. Light stays off but car starts hard first time in morning.

Any idea"s. Thanks

mbunakeith
02-17-2006, 05:54 PM
you need a trionic software update and a new throttle body. those throttle bodies have sporatic quality control

citygear
02-20-2006, 04:16 PM
I am getting a Throttle body tomorrow. Any ideas on how to get a Trionic software update? Thanks for your help.

mbunakeith
02-20-2006, 05:05 PM
the only way is to go to a dealer. if you dont want hassled, just go in, talk to the advisor and just say i need to have my trionic checked for the latest software update. chances are it needs it, but in a very rare case it may have already been done. in any case they can check with the diagnostic tool and see what version you have. you should get v. 5383377 or newer. i am not sure on the details. there are different versions for different models. there have been many updates in the last couple years. dont ask for any diagnostics or they will whack you for an hour labor on top of the programming. programming should cost 1 hour labor. call around and maybe youo can find someone to do it cheaper. 1 hour labor will be somewhere around $100.

citygear
02-21-2006, 01:43 PM
the only way is to go to a dealer. if you dont want hassled, just go in, talk to the advisor and just say i need to have my trionic checked for the latest software update. chances are it needs it, but in a very rare case it may have already been done. in any case they can check with the diagnostic tool and see what version you have. you should get v. 5383377 or newer. i am not sure on the details. there are different versions for different models. there have been many updates in the last couple years. dont ask for any diagnostics or they will whack you for an hour labor on top of the programming. programming should cost 1 hour labor. call around and maybe youo can find someone to do it cheaper. 1 hour labor will be somewhere around $100.
Thanks I will let you know how it works out.

citygear
04-03-2006, 02:55 PM
Thanks Dealer did it ok. No Charge. Cars been running great. New
code came up yesterday # 1626 or 1662 not sure. My dealer says
vac. leak on unit on fire wall black box line runs to intake . Any idea's.

Thanks

Add your comment to this topic!