stereo headunit


swimshark
02-07-2006, 08:22 PM
ok. today after my swim practice i hopped in my car, turned it on and then tried turning the radio on but it wouldnt work. when i got home i checked the fuses and everything seems fine. i dont know where the fuses are on the stereo itself but it will light up when i turn my headlights on at night but it wont play cds, radio or cassets. i went by bestbuy and they said it could be my bose amp, but i took the amp out of my old J30 and hooked it up yet it still would not work. the guy at best buy said that i would have to replace the headunit and all 6 speakers so i would have sound (tried to get me to buy $400 worth or electronics).

my first question is that if my Bose amp is blown then how is my subs amp still working? see i unplug the cord to the amp and my subs amp quits working. i plug the cord into my second amp and the subs amp works but radio still does not work.....so IS IT THE HEADUNIT OR THE AMP?

im thinking of just getting a new headunit and buying the cords to allow it to work with my bose system. does this sound ok?

jerkstore
02-13-2006, 12:35 AM
my headunit did the same thing a couple weeks ago....but a aftermarket headunit and get the watt lowering adapter. you dont need to replace the speakers or rewire the car

jerkstore
02-13-2006, 12:41 AM
oh and by the way if you would have looked down a couple posts from the top you would have seen the thread i started a few weeks ago

http://www.automotiveforums.com/vbulletin/showthread.php?t=506305

swimshark
02-13-2006, 09:29 PM
yah i got it replaced. turns out it was only the headunit

Add your comment to this topic!