Our Community is 705,000 Strong. Join Us.


Clubwagon E-250 stalls when given gas??


Ferngee
12-26-2005, 03:43 PM
1994 Clubwagon E-250 stalls when given gas but it will crank up fine.. and purr like a kitten until you try to give it gas.. I replaced the computer, the module, plugs, rotor,coolant temp sensor, oxygen sensor, map sensor, I cleaned the injectors.. and it is still stalling when you give it gas.. also while it's off if I leave the battery connected ..it will go dead in a few hours.. So what do you think is the problem???? I have been working on this van for 3 weeks now with no solution to my problem.... Help..help.. WHAT SHOULD I DO????

MagicRat
12-27-2005, 06:14 PM
As for the stalling, it might be insufficient fuel pressure and/or fuel flow. Try changing the fuel filter. If the problem persists, consider getting the fuel pressure measured. The pump may be bad, a fuel line may be pinched or the pressure regulator is bad.

The electrical problem may be trickier.
Try removing all the fuses,then unbolt the positive terminal from the battery. Use a 12 volt test light to connect the pos battery terminal and the pos cable. If the tester lights up, there is still a short on the system. Try disconnecting the starter motor cable, starter solinoid and other curcuits until the light goes out.

If the light does not illuminate, try putting in the fuses, one at a time until it lights up. That should tell you which circuit is producing the electrical draw.

Add your comment to this topic!