Quick tranny question/speed censor/1st post


xorg2
12-21-2005, 07:02 PM
Hello, I have a 99 grand caravan 3.3 and this morning the service engine light came on and it didnt want to shift out of second gear. After shutting it off and restarting, it ran fine but the light was still on. This is my 6th caravan and each time i had to replace the trans @1800.00

The service engine light never came on on the last 5 so this is a first and im hoping it wont be another 1800 bucks. After reading and searching this forum, I noticed speed censors causing this sort of problem. Lucky me the local auto zone has both the input and the output speed censors in stock for 22 bucks a piece. Can someone tell me where they are located? I'm going to pick them up tomorrow after work and see if i can get them installed assuming i dont need a lift. Great foum btw, i'm glad i found it.

eldiablo1100
12-21-2005, 10:18 PM
you have to take off the ait breather, and the sensor is right on the transmission near the shift lever

MT-2500
12-21-2005, 10:54 PM
Welcome to AF I see this is your first post.
Maybe you can luck out on this trans.
Was the code for a speed sensor?
Or did AZ just happen to have the speed sensors?
What no was the code?
And remember that a code does not say replace the sensor it points you in the direction of the problem and says to check it.
But the output speed sensor dos give a lot of trouble on the cry trans. Also check the wiring and wiring plugin good.
MT :grinno: :lol: :lol2:

xorg2
12-22-2005, 12:56 AM
"Was the code for a speed sensor?
Or did AZ just happen to have the speed sensors?
What no was the code?

I'll find out the code tomorrow when I pick them up. The guy said the'll test for free. I figure its worth the 44 bucks just to try it out before taking it to the shop.

xorg2
12-22-2005, 12:59 AM
What the other poster said about being underneath the air breather on the trans....Is this where they're both located or just one? If you know that would save me a great deal of time. I'll check this tomorrow when i get back. tia

xorg2
12-22-2005, 04:48 PM
I ju7st got back from auto zone with the input and the output speed censors. The codes were as follows:

p00734 = gear 4 ratio incorrect
p1788 = manufacturer controller trans
p0700 = trans control system malfunction

I'm not sure what these mean and i will do some research. The biggest question I have is, where the speed censors are located and which one is the input and which is the output?? They both look exactly the same and i made sure to mark both of them right out of the box.

btw the part numbers were,

wells, su1018 and wells su1034

any help would be appreciated.

MT-2500
12-22-2005, 05:36 PM
I can not help on the sensor no.
But they are different sensors. AZ messed up or some has allready switched sensors in a different box.
The code 734 is not a sensor problem.
But I think from the code P0734 you have internal problems.
Go to this link for info in a pdf on it and sensor locations
http://members.troublecodes.net/crunch/carv734.pdf
Let us know how it goes.
MT

Add your comment to this topic!