2001 Dodge Grand Caravan Sport heat problem


xxguesswho
12-04-2005, 09:32 PM
I have had my van in the Dodge dealership 5 times now because of lack of heat. Please help! When warming up the van, no heat. When driving down the road and actually pressing on the gas pedal, hot heat comes out of the vent. As soon as I let off the gas pedal, it turns ice cold.

At first, it was leaking antifreeze, so they replaced the freeze plug. Then, they said there was air in the line after they did a flush 'n fill. Then, they said there was air in the back lines, so they fixed that. Then, they replaced the thermostat (even though we had just put a new one in a week earlier, they said it was "stuck" and needed a new one). As soon as they replaced the 2nd thermostat, I had heat for just a few days. Now I'm back to no heat at warm up, shortly after heat only when pushing the gas pedal, and then no heat AT ALL! I'm freezin' here in Indiana...can anyone suggest anything? We are wondering if it's the water pump. Thanks!
vicky

B33p3r
12-05-2005, 10:46 PM
A bad water pump would cause you to overheat. Is your heat gauge getting up to temp? Also feel your supply and return hoses to the heater core. Supply should be hot and return a little cooler. If the heat is going in the supply then you should feel heat inside unless a lot of cold is getting mixed with it. Blend door. Do you have auto temp? Are you getting cold air from all vents in the van or just certain ones?

wireman2
12-06-2005, 07:27 AM
[had that happen on an Altima I had, it ended up being air caught in the cooling system. It needed to be burped. We raised the front end took the rad cap off and ran the car engine and heater for a while. weird but it worked.

xxguesswho
12-07-2005, 07:20 PM
Sorry for the delay in my response. Since I've posted, I had to take it back in and they replaced the thermostat again (#3) and put in a new radiator (said old one was leaking). Cold air is coming in all the vents, not just some of them. I've had it "burped" twice. Today, (I just got it back from the shop yesterday), I left it running to go inside the store for a few minutes, and when I came back out, antifreeze had leaked everywhere! Naturally, the heat quit working again.

vipergg
12-07-2005, 07:47 PM
Sorry for the delay in my response. Since I've posted, I had to take it back in and they replaced the thermostat again (#3) and put in a new radiator (said old one was leaking). Cold air is coming in all the vents, not just some of them. I've had it "burped" twice. Today, (I just got it back from the shop yesterday), I left it running to go inside the store for a few minutes, and when I came back out, antifreeze had leaked everywhere! Naturally, the heat quit working again.
No offense but these guys sound incompetent . It can only be 2 or 3 things . thermostat , problem with the blend doors or a totally clogged heater core , you don't even want to get into that .

C Hopper
12-16-2005, 02:53 PM
I would like to get in on the "blend door".
My 2001 Town & Country has the same problem. I'll be driving along and the heat will change temp on it's own. If I turn the temp knob to cold and back to hot, sometimes I'll get heat back right away. The hot setting will sometimes be very hot and other times be warm or cool. Could that be the "blend door"?

Thanks for any help

RIP
12-16-2005, 03:56 PM
2 more things to look at: (1) You can do an electronic self test on the ventilation system-how?-you'll have to look on this forum for the sequence (Its on several threads). It involves holdind a couple buttons on the ventilation control panel and watching for lights. (2) I could be in left field on this because I don't know if this is strictly an electrically actuated system but, many cars vent systems used to work off vacuum (yes, I'm over 40). As you move the throttle the vacuum pressure changes especially if there's a leak. Might explain why your heat comes and goes. Can anybody rule this out for him. :2cents:

xxguesswho
12-18-2005, 01:29 PM
Ok, after another visit to the same dealership (which I'm stuck with because of the warranty) they finally figured out what the problem is. It's a leaking head gasket-leaking into the spark plugs which is what caused the check engine light to come on and antifreeze to leak out-thus! no heat. I haven't got it back yet, but I'm assured-once again-that this was the problem. They did give me a brand new car to drive while they were working on this and they aren't charging me anything. Hope my experience helps someone. Thanks to everyone for your help! Happy Holidays!

Brianyev
03-06-2006, 01:56 AM
So, how did it go? Was it the head gasket replacement that solved the problem? I am having the same problem and am hoping that it isn't a head gasket situation. Please let the rest of us know if your problem is solved.

mini cooper s
10-02-2009, 10:08 AM
My 2001 grand cara van 's ignition is sporatic, the heater control is not getting power therefore no heat and unable to control direction of air flow, the compass is not working and the emergency brake light is on!!!
This all seems to have started at the same time. I've checked all the fuses and relays,I've lifted the main fuse panel up to check for corrosion all is OK.
Anyone have an idea?:banghead:

Add your comment to this topic!