Traction Control Light/Brake Lights


Josh Sutton
11-25-2005, 09:20 PM
I have 97 Eldorado that is having issues.
It all started when the traction control light came on. Shortly after that my blinkers quit working and then my tail lights quit working. I had the alternator replaced and it seemed to cure everything...but then that alternator burned out and that had to be replaced again.

At first I thought that maybe it was a bad alternator, but it has been only a couple of months since I had it replaced (for a second time) and the traction control light came on again, and AGAIN the signal lights will not work, and the brake lights will not illuminate. Weird things happen. One moment the brake lights come on and stay on, now the only one that comes on is the horizontal one in the back window and the main tail lights do not illuminate.

One last note, I have replaced the brake switch which seemed to help it for a short time (maybe a month) but then again everything is going (or should I say not going) well.

Any clue as to what could be the problem??

Thanks very any input!

joooro
01-02-2006, 05:01 PM
Josh have you gotten any Help? I was wondering what happened with your car. I had weird problems with mine once ( 1985 eldo) and when you opened the door the radio would go on.. It ended up being a bad relay and a bad fuse.....Good luck to you

Josh Sutton
01-18-2006, 05:05 PM
Nope, never figured out what was wrong. It sorta "fixed" itself...meaning it sorta went back to normal. I think that there is a bad relay like you said or something wrong with some wiring and causes the intermittent problems. I've had it in for service (dealer) and they can't give me an answer either. That just tells me it wiring or something along those lines. Thanks for the reply!

Add your comment to this topic!