loss of power.... sometimes


prendy
11-20-2005, 08:51 AM
i have a 2001 kia rio which seems to loose power sporadically. the car will run and drive but very sloooowww. the engine light does not come on so mechanic is baffled. he wants to change 1 part at a time until problem is solved, yea and thousands$$$$ later. he says it is not mechanical and probably a sensor. (who knows) i am a do it yourselfer and could replace the part but not sure where to begin. ant suggestions?

MeettheCreeper
12-08-2005, 08:41 AM
i have a 2001 kia rio which seems to loose power sporadically. the car will run and drive but very sloooowww. the engine light does not come on so mechanic is baffled. he wants to change 1 part at a time until problem is solved, yea and thousands$$$$ later. he says it is not mechanical and probably a sensor. (who knows) i am a do it yourselfer and could replace the part but not sure where to begin. ant suggestions?


We have had problems with the Mass Air Flow sensors causing this symptom and not throwing a fault code.

prendy
12-08-2005, 08:47 PM
We have had problems with the Mass Air Flow sensors causing this symptom and not throwing a fault code.
thanks for your insight i will change it out but now have a new problem where when the car is started it will stall, this will occur over and over until the car is totally warmed up and now the engine light is on, i do hear a strange air noise when i rev the motor trying to keep it running, almost sounds like a vacuum leak but from what i can tell all the hoses seem to be where they should and intact, this car will keep me on my toes. thanks in advance for any help

MeettheCreeper
12-09-2005, 11:19 AM
thanks for your insight i will change it out but now have a new problem where when the car is started it will stall, this will occur over and over until the car is totally warmed up and now the engine light is on, i do hear a strange air noise when i rev the motor trying to keep it running, almost sounds like a vacuum leak but from what i can tell all the hoses seem to be where they should and intact, this car will keep me on my toes. thanks in advance for any help

There is a vacuum line beneath the airbox that connects to the valve cover. Sometimes the vac T gets cracked when the airbox is removed.

ALso there is a low speed engine stall reprogramming for Rio. Should be done by the dealer at no charge to you.

If you can get the code from say Auto Zone or the like I may be able to give you a starting point.

queen b
03-12-2006, 08:41 AM
i had a similar prob with my 2000 rio it would drive really good then id lose lots of power and the car would slow down even with the pedal on the floor. all i had to do was change the spark plugs never happened again if that doesnt work get it serviced and they should be able to tell u how to fix it if the sevice didnt.

Add your comment to this topic!