"TRANS FAILSAFE PROG" message on dashboard of '95 BMW 740iL


limonboy
10-27-2005, 11:05 AM
If there is anyone who can help me out. I just recently got a '95 BMW 740il. It has 94,000 miles. Everything works fine, except when I step on the gas, usually in 1st gear, and the car begins to stutter and it gives me a message saying "TRANS FAILSAFE PROG". This only occurs when I step on the gas while on the 1st gear (in automatic). It engages properly in Sports Mode (S4), where it will upshift and downshit properly. the problem only occurs in the drive mode (D). As the car upshifts to 2nd and 3rd gears, it starts to pick speed, but often times, it will do the same stutter, also when I'm lowering the speed and suddenly step on the gas again, it does not respond correctly when I step on the gas, as the car is stagnant while my foot is on the gas pedal and the car takes time to accelerate.

I was told to check the transmission fluids to see if these are in good order, which I did, and the fluid level is right, however, somewhat varnished and has some dirt in it. It most likely looks like it (the fluid) needs to be changed. I was also told to use the Lucas Oil Transmission Fix before I do any major work on the tranny. Are there any other suggestions about this Lucas Oil or anything else someone could give me, because I don't want to go the BMW dealer, because all they do is tell you to buy a new transmission (the lazy man route). PLEASE HELP N' ADVISE. I appreciate any suggestions with this problem.

muleman
10-28-2005, 07:45 AM
limonboy
You do not indicate how many miles or which transmission you have in your car. I had a similar problem with my 1994, although not to the same degree. Turns out that there was a technical service bulletin (TSB 240394, DEC 1997) related to the transmission EPROM. (Don't know if this applies to your car, however this is something that I had the dealer replace. ($125 parts and labor)
There was also a TSB (240497 NOV 97) related specifically to the 1995 model year that had something to do with upshifting when cold, but I don't know the details - check alldata.com.
When I had the EPROM replaced, I also had them perform the 100K mile transmission service - replace O-rings, gasket, filter, fluid, etc. which cost $245. Been running for a 25k miles now with no problems..
I would seriously consider getting that fluid replaced before the valve body fails, as this is big bucks. (> $3000) Good luck!
muleman


If there is anyone who can help me out. I just recently got a '95 BMW 740il. Everything works fine, except when I step on the gas, usually in 1st gear, and the car begins to stutter and it gives me a message saying "TRANS FAILSAFE PROG". This only occurs when I step on the gas while on the 1st gear (in automatic). It engages properly in Sports Mode (S4), where it will upshift and downshit properly. the problem only occurs in the drive mode (D). As the car upshifts to 2nd and 3rd gears, it starts to pick speed, but often times, it will do the same stutter, also when I'm lowering the speed and suddenly step on the gas again, it does not respond correctly when I step on the gas, as the car is stagnant while my foot is on the gas pedal and the car takes time to accelerate.

I was told to check the transmission fluids to see if these are in good order, which I did, and the fluid level is right, however, somewhat varnished and has some dirt in it. It most likely looks like it (the fluid) needs to be changed. I was also told to use the Lucas Oil Transmission Fix before I do any major work on the tranny. Are there any other suggestions about this Lucas Oil or anything else someone could give me, because I don't want to go the BMW dealer, because all they do is tell you to buy a new transmission (the lazy man route). PLEASE HELP N' ADVISE. I appreciate any suggestions with this problem.

BMW_Omar
05-13-2012, 06:16 AM
Hi Limonboy

I had the same message but I got it by doing something completely different, I had a problem with my BMW 1995 740IL, My cigarette lighter has blown for some reason as I was using the lighter to charge my mobile every day, so I though that is an easy job just went to an electrician shop and I bought off him a normal fuse in which I replaced myself at the trunk, near the battery where are fuses located, then I came and turned on the engine and suddenly I saw new message on the dashboard "TRANS FAILSAFE PROG" and the steering wheel got heavier, and I press and the car won't accelerate, I barely drove the car into a mechanic and he plugged a small computer into the car and reprogrammed everything, but I still can't plug in anything into the lighter. I do not know what happened is there a short circuit somewhere.

Add your comment to this topic!