Our Community is 705,000 Strong. Join Us.


Help Please!!!


CHARITYCJ
09-28-2005, 10:42 PM
I've recently run into a problem, see if this hits home with anyone, and if you have any ideas on what the problem is, please...share.

Whenever I get in to start my Amigo, it turns over...starts for half a second then cuts off, after doing this several times, I must push the gas all the way down and let it wind high and hard until it makes a sort of pop sound, like a backfire, then and only then will it stay cranked. This happens whenever the car needs to be cranked, even after having driven for a while. Dad changed the gas filter. Didn't change anything. He thinks it could be the injectors, but I had someone mention the TPS (throttle position sensor). That sounded good, but all the information I've read about the TPS mentions nothing about hard starts...only mentioning a rough ride and idle. Neither of which is a problem once I've started the car. Please, any help would be greatly appreciated, simply because cranking my car takes about 2-3 dollars in gas at a time...and we all know gas is getting out of hand $$ wise.

THANX, Charity

amigo-2k
09-28-2005, 11:06 PM
seeing that you have a 91, your timing might be off?

maybe a new Cap and rotor?

When was the last time you had a tune up?

CHARITYCJ
09-28-2005, 11:11 PM
seeing that you have a 91, your timing might be off?

maybe a new Cap and rotor?

When was the last time you had a tune up?

A tune-up was performed less than a month ago.

brayburks
10-03-2005, 08:07 PM
I'm having the same problem with my 99 amigo V6(50k). I actually was just looking for a solution to that problem, myself. When I try to start the vehicle, it will run for about 1.5 seconds, then shut off. The second time I try to start it, it almost seems that it is flooded with fuel because it is hard to start. Then when it does start, it sputters for a few seconds then straightens out. After that it runs fine...until the next time I try to start it. It just started to do this, and seems to be getting worse by the week. Any help would be greatly appreciated.

amigo-2k
10-03-2005, 09:29 PM
the key things to look at and replace are:

the fuel filter (yours could be plugged)
your fuel pressure regulator
Or you have a leaky intake manifold gasket (very common).

please see the FAQ link in my sig below for more info.

Add your comment to this topic!