Code C1226. RF Hub Replacement


PHXAuto
09-12-2005, 02:57 PM
I have a 98 Olds Intrigue. About a month ago the “service Vehicle Soon”, ABS and trac Control lights all came on. When I shut the car off and then restart, the lights are not on but once I reach about 20MPH, they all come back on. I took it to a shop that I trust and they ran the codes. Code C1226 came on indicating “RF Excessive Wheel Speed Variation” along with C1223: LR Wheel Speed Sensor Input Signal is 0. They couldn’t recreate the C1223 code so they suggested a Right Front Hub replacement. They quoted around $600 for this work and recommended using a factory replacement part. I took the car home without the repair and over the weekend replaced the right front hub with one I purchased from Auto Zone for about $135. Took a test drive and the lights still came on. I then replaced the left rear hub and this also did not fix the issue. I have now put the originals back on the vehicle and need anyone’s help as to cause and corrective action. Is it possible that the aftermarket item doesn’t work correctly thus giving the indication? Is there something else I can try? Thanks for all of the help. R, Walt

panzer dragoon
09-12-2005, 05:25 PM
who gave you these codes?

C1226
C1223

For some reason they are not on the alldatadiy.com Intrigue list. Did they use a Tech2 or some other scanner?

Additional Diagnostic Trouble Codes
ADDITIONAL DIAGNOSTIC TROUBLE CODES
These are the only ABS diagnostic trouble codes for this vehicle. Additional ABS diagnostic trouble codes obtained with an aftermarket scan tool are not valid ABS trouble codes. Contact the aftermarket scan tool manufacturer for additional assistance.

The AllDataDiy.com C list for Intrigue
C Code Charts
. C0035
. C0036
. C0040
. C0041
. C0045
. C0046
. C0050
. C0051
. C0060
. C0065
. C0070
. C0075
. C0080
. C0085
. C0090
. C0095
. C0110
. C0121
. C0131
. C0132
. C0141
. C0146
. C0151
. C0156
. C0161
. C0186
. C0187
. C0196
. C0197
. C0236
. C0240
. C0241
. C0244
. C0245
. C0252
. C0253
. C0550
. C0710
. C0870
. C0875
. C0896

kmohr3
09-12-2005, 10:02 PM
good question - the Helm (factory) manual doesn't list them either....

panzer dragoon
09-12-2005, 10:30 PM
so your codes might be bogus. You might need to go to GM and get a tech2 scan done to get the correct codes. I really don't know, I'm just going with what alldatadiy is saying.

Somebody here might be able to interpolate those bogus codes and come up with a diagnosis. --Or may have had the same codes.

PHXAuto
09-13-2005, 09:20 AM
I checked the codes on http://www.regalgs.org/obd2.htm.

Again, I trust the shop that told me this but one can never tell.

Thanks for the help so far.

panzer dragoon
09-13-2005, 03:42 PM
These are the only ABS diagnostic trouble codes for this vehicle. Additional ABS diagnostic trouble codes obtained with an aftermarket scan tool are not valid ABS trouble codes. Contact the aftermarket scan tool manufacturer for additional assistance.

For some reason the Tech2 (GM service scanner/programmer) is the only scanner that can read the codes appropriately. Usually this is not the case, but for ABS it is.

I would go to another a GM service center and have your car scanned again to get the correct diagnostic codes.

The OBD2 codes you have right now are not valid OBD2 codes for the Intrigue.

kmohr3
09-13-2005, 08:36 PM
I'm not sure what excessive wheel speed variation means, but, by any chance does the car have some mis-matched tires possibly? Maybe for some reason the right front wheel is turning a little faster, or slower than it's supposed to - just a guess

pgarcia53
09-13-2005, 09:37 PM
I have a 2001 Intrigue and had the same problem at about 85000 miles. Same symptoms-Service Vehicle Soon light would go off after shutting off, but as soon as the vehicle hit 15-20 mph, the light came on again. Was told that it was probably a bad sensor, but the sensor is integral to the hub assembly and could not be replaced separately. A new OEM hub fixed the problem.

Add your comment to this topic!