Our Community is 705,000 Strong. Join Us.


1994 Dodge Ram stalls when idling


sonicfleck
08-10-2005, 01:18 PM
I have a 1994 Dodge Ram 1500, 5.9L V-8, AT, with about 115,000 miles on it.

At about 60,000 miles the truck randomly started stalling at idle. Didn't matter if I was in gear or in neutral. After 2-3 days the problem disappeared. Since then the problem has reappeared without notice 3-4 times and has disappeared within 2-7 days every time.

If I keep my foot on the accelartor a little, I can get it to idle at about 700 rpm fine but as soon as I remove my foot, it stalls out on me. If I rev it up to about 5,000 rpm a few times it will usually correct the problem for a while (most of the times till the truck is shut off).

Between the first time this happened and the most recent time (today) I have changed the plugs, wires, rotor, cap, air filter. None of these changes coincided with any problems, but I doubt they are the source as they have all been replaced. No idiot lights have ever gone on.

Does anyone have any ideas? I am completely perplexed as the problem always goes away without me doing anything and does so for extended periods of time (last time it did it before now was 2.5 years ago)

Thanks for your help!
Thomas

dodge99
08-13-2005, 03:53 AM
mine has been doing that to its a 99 2500 5.7 ....i think it is the o2 sensor down on the exhaust in the front, you will see a wire hooked to
it ....but i am not sure yet if that is what it is yet, if you find out let me know.

sandman96
08-13-2005, 10:08 AM
My truck did that for a while. I ended up taking it to the dealer to have it fixed. It was the throttle position switch. Cost $100 to have it replaced from the dealer.

dodge99
08-14-2005, 02:41 PM
found out what my problem was, mine is a 5.9 liter sorry for the mistake earlier, i havent been driving it because of the gas prices here in michigan, anyway it was the ground on the battery, at the battery, all corroded i grabbed it and it popped loose. problem solved got out of it easy this time.

RICHARD312
08-16-2005, 05:33 PM
lol, I.A.C. $40.00. Change It.

TheRodGod
09-29-2005, 09:59 PM
I have a 1994 Dodge Ram 1500, 5.9L V-8, AT, with about 115,000 miles on it.

At about 60,000 miles the truck randomly started stalling at idle. Didn't matter if I was in gear or in neutral. After 2-3 days the problem disappeared. Since then the problem has reappeared without notice 3-4 times and has disappeared within 2-7 days every time.

If I keep my foot on the accelartor a little, I can get it to idle at about 700 rpm fine but as soon as I remove my foot, it stalls out on me. If I rev it up to about 5,000 rpm a few times it will usually correct the problem for a while (most of the times till the truck is shut off).

Between the first time this happened and the most recent time (today) I have changed the plugs, wires, rotor, cap, air filter. None of these changes coincided with any problems, but I doubt they are the source as they have all been replaced. No idiot lights have ever gone on.

Does anyone have any ideas? I am completely perplexed as the problem always goes away without me doing anything and does so for extended periods of time (last time it did it before now was 2.5 years ago)

Thanks for your help!
Thomas
Try cleaning your throttle plates.Had the same problem,worked for me.
Sounds funny but true.(Clean, not scrape)Hope this helps.
TheRodGod

sonicfleck
01-26-2007, 12:36 AM
I have a 1994 Dodge Ram 1500, 5.9L V-8, AT, with about 115,000 miles on it.

At about 60,000 miles the truck randomly started stalling at idle. Didn't matter if I was in gear or in neutral. After 2-3 days the problem disappeared. Since then the problem has reappeared without notice 3-4 times and has disappeared within 2-7 days every time.

If I keep my foot on the accelartor a little, I can get it to idle at about 700 rpm fine but as soon as I remove my foot, it stalls out on me. If I rev it up to about 5,000 rpm a few times it will usually correct the problem for a while (most of the times till the truck is shut off).

Between the first time this happened and the most recent time (today) I have changed the plugs, wires, rotor, cap, air filter. None of these changes coincided with any problems, but I doubt they are the source as they have all been replaced. No idiot lights have ever gone on.

Does anyone have any ideas? I am completely perplexed as the problem always goes away without me doing anything and does so for extended periods of time (last time it did it before now was 2.5 years ago)

Thanks for your help!
Thomas

Since this post 18 months ago, the stalling quit. . .then I drove the truck to South Carolina (moved here) and it started stalling about 1/2 way here. Didn't go away after several months. . .so I replaced the I.A.C and cleaned the throttle body with a toothbrush and some carb cleaner.

Stalling is completely gone, and it runs better than I ever remember!!

-thomas

cliff1
01-26-2007, 05:57 PM
A quick question what is a I.A.C.??

Thx
Cliff

sonicfleck
01-26-2007, 07:22 PM
A quick question what is a I.A.C.??

Thx
Cliff

I.A.C. = Idle Air Control Valve. It adjusts the amount of air to let in when the engine is at idle. What happens is they get carbon buildup on them and stick.

It took about 10 min. to change. You could probably take it out, take it apart and rebuild it quite easily. . .but I just put a new one in.

Had the same issue with my mom's Expedition too. . .just FYI.

Let me know if I can be of any help.

-thomas

cliff1
01-26-2007, 11:12 PM
Thx alot for the info, where would i find it on my 98 2500 5.9 360.

Thx in advanced

Cliff

sonicfleck
01-29-2007, 04:50 PM
Thx alot for the info, where would i find it on my 98 2500 5.9 360.

Thx in advanced

Cliff

Should be on the back side of the throttle body. There is an electrical plug that goes to it.

If you can't find it, let me know and I'll take a couple pictures of mine and send them to you.

-t

The Fast Forester
01-29-2007, 10:31 PM
Would you mind copying me on those pictures t? I tried to get somebody to tell me how to change my IAC valve a while ago and came up empty. I'm having idle issues with my '01 1500 p/u.....will idle up, then down, then up again just sitting there. Thank you!

sonicfleck
01-29-2007, 10:37 PM
Would you mind copying me on those pictures t? I tried to get somebody to tell me how to change my IAC valve a while ago and came up empty. I'm having idle issues with my '01 1500 p/u.....will idle up, then down, then up again just sitting there. Thank you!


No problem. email me at sonicfleck at gmail.com and I'll send you some pictures.

Mine did the idle up to about 1200 rpm, then almost stall out, then up, then down for a while too.

It will probably be Wed or Thursday before I can take the pics though as I'm going snowboarding tomorrow and won't get home till late.

My truck is a 94, so I can't promise everything is exactly the same. . .but changing it on my truck was quite easy.

-thomas

Add your comment to this topic!