80 + oil pressure on 89 s10 blazer 4.3


lostmartian63
08-09-2005, 08:53 PM
My 89 blazer with a 4.3 has very high oil pressure ive changed the oil and filter and made sure it doent have to much oil but its still very high. Ive been told this isnt bad for the engine but something about that makes me unsettled. Please give me some info on what the fix for this could be. Thx

s10blazerman4x4
08-09-2005, 09:31 PM
Have you looked at the oil pressure switch mounted next to the distributor on the drivers side?Could have a loose bad wire or need a new one.

BlazerLT
08-09-2005, 10:01 PM
My 89 blazer with a 4.3 has very high oil pressure ive changed the oil and filter and made sure it doent have to much oil but its still very high. Ive been told this isnt bad for the engine but something about that makes me unsettled. Please give me some info on what the fix for this could be. Thx

How high is it?

You oil pressure sender might be defective.

It is beside the dist. cap and not on the actual distributor.

Do a search for it and you will get some threads with info.

s10blazerman4x4
08-09-2005, 10:17 PM
How high is it?

You oil pressure sender might be defective.

It is beside the dist. cap and not on the actual distributor.

Do a search for it and you will get some threads with info.
Have you looked at the oil pressure switch mounted next to the distributor on the drivers side?Could have a loose bad wire or need a new one.

That is what i said.I never said it was on the distributor.I would know i had to replace mine.You will need the socket for that and then some creative bending to get the new one in.

lostmartian63
08-09-2005, 10:49 PM
the gauge is compleatly topped out Ill look at the pressure sender tonight thx

blazee
08-09-2005, 10:52 PM
If the gauge stays pegged, I'd lean toward a problem with the wire.

lostmartian63
08-10-2005, 09:26 PM
Well I checked the wiring and its fine but I was letting it idle for a while today and I noticed at idle it fluctuates pretty rappidle from 40-60 but as soon as you give it throttle it jumps back up to the pegged out pint im going to get the new part on friday and put it on and see what that does. Ive seen several different ones for it. Some say w/ light and some say w/ gauge does this mean the part has a light or gauge or the vehicle? What would be best to buy for it?

s10blazerman4x4
08-10-2005, 09:45 PM
Get the one with the gauge.

lostmartian63
08-10-2005, 10:29 PM
thx. ohh and the creative bending part, no prob Ill just make a tool for it I work in a macine shop 3rd shift sometimes.

s10blazerman4x4
08-10-2005, 11:28 PM
Kool thats the way to go.

Rmbodie
08-11-2005, 06:54 AM
That looks like good pressure to me , My 89 starts out a little above 50 . and drops to around 30 when it warms up . that sensor is a #$@%& to get to . I currently have my distributor and intake man off and I was considering adding a mechanical one for double coverage . My neighbor has a 95 with the same dash . WE BOTH are having issues with the instrument readings on the volt meter . Mine reads around 12 when the true output is 14.5. His reads 18 when true is 14.0 . So you may have an issue with your dash gauges . Just a thought . Rob

Rmbodie
08-11-2005, 06:57 AM
I did a 3" body lift . It is easy to get to now .No creative bending . So do a lift kit first . HAHA

lostmartian63
08-11-2005, 11:52 AM
I did a 3" body lift . It is easy to get to now .No creative bending . So do a lift kit first . HAHA


Actually I have a 86 thats just sitting here and has a 3 inch body lift but i hate the way body lifts look and their compleatly useless. All they do is allow you to clear bigger tires and make the possibility of your truck flipping much greater. and besides I can get to it fine like I said Im going to make a tool for it at a maching shop.

Add your comment to this topic!