annnoying drill noise from stereo


ouzo
07-13-2005, 10:13 AM
hi there, i have a 98' sunfire w/ 2.2l engine. i have this annoying problem with my speakers. the higher i rev the engine the higher pitch noise i hear coming from the speakers. i disconnected and reattached and checked again the wiring i have on my aftermarket headset and amp. but it won't go away. it sounds like an annoying dentist drill! any takes on what i can do? this is a pretty new and annoying problem with my car. thanks~!

L|_|da
07-13-2005, 11:46 AM
disconnect the power to your amp and check it, what kind of amp is it, and while were at it what all is in your system? Headunit, speakers, subs(?), amps, nav units anything else thats been added in.

PaulD
07-13-2005, 01:08 PM
it's almost always noise from the RCA's, try using UTP's (unsheiled twisted pair) and run them down the center of the car. The center tends to be the "quietest" place

Jeremy86
07-14-2005, 12:32 AM
Sounds to me like you are having a problem with alternator whine, it's a common problem. Here is what I suggest, I've had problems with both of my Headunits. Ok, first thing to do is get a different set of RCAs and just run them back to the amp, just have them on top of your seats and all. If the sound is still there, go to the amp and slowly unglug the RCAs, if sound goes away, your preouts on your head unit are bad. Also, if you can get them to reach, have someone else's CD player, hook your RCAs to it and see if there's noise. If no noise, once again your head unit is bad. i've had 2 headunits go bad from heat I am pretty sure. I hope this helped.

PaulD
07-14-2005, 01:07 PM
wow, I don't get engine noise in my installs ........

Jeremy86
07-14-2005, 01:08 PM
I don't either, but my head units go bad from heat causing my preouts to go bad. I could throw in someone else's CD player in their car, with my RCAs and it would work. No matter where I ran my wires it would make noise, different amp, made noise, new cd player, no noise.

Add your comment to this topic!