01 Rodeo That I Just Bought


ADUNCAN
06-29-2005, 06:23 PM
Hey I am not for sure what is going on I just purchased a 01 rodeo from an auction so I know very little about the vehicle. WHile I am driving it, it will just cut off for no reason it does not miss or anything no warnings it just cuts off, but restarts like a charm. It has 67,000 miles on it and has a slight problem with the idle as well even when your foot is on the gas the rpms are moving---they just dont seem to be in sync with the speed at all times while driving.....I am female and no nothing about vehicles can anyone give me some insight. I did use some fuel injector cleaner from auto zone and some octane booster for the rattly valves.

Ramblin Fever
06-29-2005, 08:16 PM
The idling/stalling issue sounds like symptoms of intake manifold gasket crack, common on the 98+ yrs. That truck may or may not be under warranty for that, not sure.

For the "rattly valves", I think, not positive here, that the 01's are mechanically adjustable on the V6. Look at your owners manual to see if any adjustments are needed at a certain mileage, possibly 60K. If so, definitely get that scheduled.

If your valves/lifters are hydraulic = NON-adjustable, let me know, I have more info on the hydraulics.

You didn't say what engine you have?

FWIW, octane booster will not help the valves any, in fact, I don't think it's good for an engine to have that particular additive. :confused:

amigo-2k
06-29-2005, 11:33 PM
sounds like the intake manafold gasket. Classic problem. See the FAQ's for more info.

then report back here if you continue to have that shut off problem.

ADUNCAN
07-01-2005, 03:06 PM
Just Wanted To Follow Up And Let Everyone Know That It Was A 8.00 Fuel Filter That Was Causing My Problems----

Add your comment to this topic!