Transmission???


azlan755
06-21-2005, 01:41 AM
I am considering buying a 99 GMC Jimmy: V6 vortec 127,000 miles 4x4 w/ 4 doors. Upon test drive the transmission would whine until I reached 35-40 mph then it would quiet down. I've asked several people and have gotten no answers as to why this is happening. The sound is not annoying but enough to make you question it. Also the "service 4 wheel drive" light is on and the buttons allowing you to turn 4 wheel drive on, will not light up. Does anyone have and suggestions or recommendations? Any help would be appreciated
Thanks

rlith
06-21-2005, 07:18 AM
If it has a whine and it's definatly the transmission then I would move on... Or demand to take it to a transmission shop before purchase (any good buyer will let you) so you can have an independant check it out.

blazes9395
06-21-2005, 09:13 AM
Transmission whine, like the one your describing, is most likley being caused by the transmission oil pump wearing out. As you accelerate, you put pressure on the pump, causing it to whine. You don't hear it as you pick up speed because its spinnig fast, and the whine diminishes - but its still there and will continue to get worse. Answer me this; does the whine go with tire speed or does it go with engine speed. If it is with engine speed, tranny pump for sure.

azlan755
06-21-2005, 02:29 PM
Thanks for the advice. I couldn't tell you if the sound goes with the engine or tire speed. It seems to increase in volume slightly as you accelerate then it drops off at around 40 mph. Once again thanks for the advice I will take it into consideration

Add your comment to this topic!