Very poor acceleration


bighops2000
06-20-2005, 02:31 AM
My rodeo does not accelerate worth a crap. i have a 3.2v6 and i know it should accelerate much better than it does. i have changed the oil, and fuel filters and i have used the lucas fuel injector cleaner. my after market filter is less than a year old. i almost feel like the tranny is leaving b/c it takes so long the get up. would a tranny flush help. what could be the problem

rodeo02
06-20-2005, 10:51 AM
Are you sure you are starting off in 1st gear? If the trans is in limp mode, you will typically start off in 3rd, which will give a sluggish take-off. Put the floor shifter in 1st & shift manually to see if thier is a change.
G/luck
Joel

bighops2000
06-20-2005, 11:27 AM
Are you sure you are starting off in 1st gear? If the trans is in limp mode, you will typically start off in 3rd, which will give a sluggish take-off. Put the floor shifter in 1st & shift manually to see if thier is a change.
G/luck
Joel

its an automatic 2wd

rodeo02
06-20-2005, 01:16 PM
its an automatic 2wd

Yep, I assumed that since you asked about a trans "flush". Can't really flush a manual trans. Try what I suggested. Shift your automatic manually to see if there is a performance change.
G/luck
Joel

bighops2000
06-21-2005, 02:30 PM
Yep, I assumed that since you asked about a trans "flush". Can't really flush a manual trans. Try what I suggested. Shift your automatic manually to see if there is a performance change.
G/luck
Joel

i tried and it was a little different maybe only becuase i was looking for something bvut it seems like it was picking up faster whats the casues of that.

rodeo02
06-22-2005, 12:57 AM
i tried and it was a little different maybe only becuase i was looking for something bvut it seems like it was picking up faster whats the casues of that.

When you put it in "D", you may not be starting out in 1st gear, but 2nd or 3rd instead. This could be a faulty "winter" mode switch, a bad range/mode sensor, or an internal transmission problem.
G/luck
Joel

bighops2000
06-26-2005, 02:37 AM
tranny flush did the trick WOO HOO!

Add your comment to this topic!