96 rodeo-no horn, no right turn signal


dgruginski
06-18-2005, 01:31 AM
Just got some time to work on my 96 rodeo. The horn hasn't worked for awhile which has probably kept me from getting shot from road rage but otherwise it would be nice to get it working. The horn death co-incided with a check engine light so thought it might be related. I've checked relays and swapped a couple but that didn't seem to help. Also, I got into a fender bender and when I flip on my right turn signal the dash has a fast flashing and clicking noise and only the rear flasher works...the front one just stays solid. The left turn signal works fine. Any help/advice would be appreciated ...thanks

Canucklehead
06-18-2005, 07:05 AM
Just got some time to work on my 96 rodeo. The horn hasn't worked for awhile which has probably kept me from getting shot from road rage but otherwise it would be nice to get it working. The horn death co-incided with a check engine light so thought it might be related. I've checked relays and swapped a couple but that didn't seem to help. Also, I got into a fender bender and when I flip on my right turn signal the dash has a fast flashing and clicking noise and only the rear flasher works...the front one just stays solid. The left turn signal works fine. Any help/advice would be appreciated ...thanks

Can't help you with the horn issue but have you tried replacing the turn signal bulb or swapping it with the left turn signal bulb? Swapping bulbs will at least let you know if it's in the wiring or just a bad bulb.

dgruginski
06-18-2005, 07:39 PM
thanks for the reply...actually it was the bulb...I had changed it last week with what I thought was a good spare when it was getting dark outside. I pulled it out today and noticed part of it looked burnt out. I replaced it and blinking is back...thanks! now to figure out if I just need to buy a new horn.

Add your comment to this topic!