01 Rodeo Sport ABS problem


jeanne vanwilpe
05-31-2005, 12:35 PM
Have 01 Rodeo Sport 2wd with 93K miles. In the last 2 weeks have had problem twice with brakes when at a dead stop, the brake peddle starts thumping and I hear grinding noise, peddle goes to the floor and truck lurches forward. Came very close to rear ending someone both times. Did not notice if ABS light came on, if it did, does not stay on. Planning on taking to dealer this week but if it doesn't duplicate when they drive it I know they won't do anything to fix it. Also check engine light has been coming on sporatically. Could they be related issues ? Any ideas or suggestions would be greatly appreciated.

amigo-2k
05-31-2005, 12:47 PM
What engine?

If you are worried that the ABS is malifuctioning I would just pull the ABS fuse (this will turn the ABS off).

If you problem still happens it is most likely a problem with the master cyclinder.

Also head to autozone to have your CEL codes read for free.

jeanne vanwilpe
05-31-2005, 01:06 PM
It is V6 3.2L. Will try your suggestion. If it is the master cylinder, do you know if that is covered under the 10yr 120K warranty ? Thanks

amigo-2k
05-31-2005, 02:01 PM
Any mileage over 60k it only covers the power train (inside the engine, gaskets, oil leaks, tranny, front and rear diffy).

rodeo02
05-31-2005, 02:51 PM
jeanne, from what you describe, it sounds like the ABS is activating when it shouldn't be. It's likely a wheel speed sensor issue. Very common when an ABS equipped vehicle gets some miles on it. Like Ryan says, pull the ABS fuse from the under-hood fuse box until you can get it addressed. This will disable the ABS, your brakes will then function as normal, just like a non-ABS vehicle.
G/luck
Joel

Add your comment to this topic!