Our Community is 705,000 Strong. Join Us.


Headlight don't work but tail lights do.


amansopoor
05-14-2005, 05:37 PM
I have a 89 SSE, when I turn on the headlight switch the headlights don't come on but the tail lights and marker lights do come on. I tried to trace the wiring but i could find anything, I thought I would take a wire and jump the back of the headlight switch to see if I could get them to work and the did so I thought I would replace the switch and the same problem was there I tried 3 switches nothing seems to work and I don't know what to do.

randman1
05-16-2005, 09:19 PM
Your tail lights are on a different circuit than the headlights. What color wires did you jump to get the headlights to work?

magicalninja1981
08-21-2005, 11:09 AM
I have the same problem on my 86 Parisienne!! It's really aggitating because I too tried other switches... when you replace the switch, the headlights will turn on if the car is off. As soon as you start the car they flick off and all I can use are my brights.

The even stranger thing is that when the brights are switched on, the 2 low beam lights come on too.

I found that on these cars there are 4 headlites. Only one on each side will act as bright and the other 2 will stay low beam.

Now what really confuses me is to why those 2 low beam lights will work when I have the brights clicked on but when the low cycle is switched i have nothing.

At first I concluded that it was a bad ground connection. However, I cleaned all the ground connections and the lights are still doing the same thing!!! Everything else works 100% better but the lights are really making me mad.

Any suggestions on how to fix the low beam cycle on this beast?

magicalninja1981
08-21-2005, 04:43 PM
Finally figured out what the problem was!! Both low beam head lights blew. WTF is up with that?!?! Crazy Gm products never fail to amuse me. Anyways I changed out the head lights and the switch, now everything works great! Ohhh did help quite a bit to clean off all the ground points.

Add your comment to this topic!