Vision/ Intrepid/ Talon Timing Belt must be replaced before it goes bad?


skeedo
04-27-2005, 12:57 PM
I am told that if you do not replace the timing belt in a mid-late 90s vision/intrepid/talon that it will destroy the engine when it goes out.

Is this true or just a big hoax?

AWP9521
04-30-2005, 04:02 PM
I can't speak for Talons, but Visions, Intrepids, and Concordes are all the same except for the front and rear looks, if they have the 3.5 Liter V6 Engine it is recommended to replace the Timing Belt at around 100K or if the Water Pump goes before then since it is also driven by the belt. Failure to do so may indeed put your engine in jeopardy if the Belt does let go, these are "Interference" Engines and thus if the belt breaks while the engine is running then certain damage to the Valves and Piston Domes can result. This does not apply to the 3.3 Liter V6 Engines as they have a Timing Chain.

92_Astro
07-28-2005, 09:21 AM
Actually, I have a 95 Vision TSi, and my timing belt slipped about 2 years ago, the water pump was leaking onto the tension pulley and caused it to fail, thus loosing tension on the belt. It happened as I was driving about 25 miles per hour.

All the research I did told me the 95 3.5 was NOT an interference engine, but the 94 was.

Anyway, I purchased a kit that had the belt, water pump and pulley together for about 130 dollars. did the repair myself and saved a ton of money.

seabaughs
12-22-2005, 11:06 PM
I have a 94 Vision (3.5). It's a non-interfearance engine. My timing belt broke and I replaced it. I replaced the water pump since I was in there. My belt tensioner was frozen also, so I replaced that. It's been running great for 3 years now.

photogtp
07-18-2007, 02:28 PM
Is there any write ups on how complicated changing out the belt can be? Being a DOHVC engine has me a little worried.

This is for a 96 Vision Tsi.

Riordo
06-03-2008, 10:08 PM
I need to know if the 1997 3.5L v6 is interference or zero clearance or whatever the case may be, ive read that users on this forum have replaced their 94/ 95 timing belts with the 3.5L motor. Im about 90% sure its the belt - i have no compression also and im hoping that its the timing belt otherwise im without a car and job lol. Please someone help me with this problem...

my car's temp went almost to the red line above the H on the temp guage - i pulled over and shut her off... my dad came and we put coolant in, i cranked it 3 times and she started drove about a quarter mile on the back roads and the temp climbed steadily... pulled onto a side street and AAA towed me home. an hour later tried to start it with no avail. she just spun up; i was told by a friend who looked at it that there was no compression in the cylinders (under the spark plug) and told me my car was junk!!!! please help!!!

any info at all good or bad would be appreciated greatly

Riordo
06-03-2008, 10:13 PM
you may want to consider picking up a Haynes repair manual at your local pep boys, auto zone, CAP or whatever the case may be... this is what you will want http://www.haynes.com/products/sfID1/3/sfID2/5/sfID3/37/productID/99
this should help you out - covers fulls tear down and rebuild of entire car has helped me out of a lot of jams gluck

Add your comment to this topic!