R33 sputter on higher RPM


GTRVspec33
04-21-2005, 03:13 PM
Can someone please tell me why my car would sputter when i reach 3200 rpm and higher? I have the HKS EVC and injector contoller installed. Even tho I turned it on or off, it sputters. Anyone know what is the problem? please help. :crying:

tazdev
04-22-2005, 02:06 AM
checked your plugs recently?

GTRVspec33
04-22-2005, 04:36 PM
i did check the plugs. It seems good

SkylineUSA
05-08-2005, 01:36 AM
I just worked on a R33 GTR last night with the same problem. I swapped the MAFs, with the ones on my GTR and it fixed the problem, so I would check the MAFs. Take them off and give them a good spray with carb cleaner. Remeber they are very delicate. I have cleaned them with a brush and alcohol, but you have to take off the screen for that. If you do have to go that route, take the engine side screen off, not the screen on the filter side.

SkylineUSA
05-08-2005, 01:38 AM
I did not read the part about the EVC, you might have an issue with that, but try the MAFs first.

tyndago
08-16-2005, 07:17 PM
Bad plug, bad coil,bad maf, bad tune.

Weird at about 3200 rpms. Not normal rpm. Normally its around 2500 ish or 4500 ish.

davehack
09-12-2005, 05:16 PM
can someone please tell me what maf's means cause l am having the same problem with my car

tyndago
09-13-2005, 10:57 AM
MAF is mass air flow meter. They have emotional difficulties at times.

davehack
09-14-2005, 02:47 AM
l am having same problem but it is only when l am running 12 psi not when l am running the standard boost anyone got any idea's or is it the same problem

tyndago
09-14-2005, 08:43 AM
You have bad plugs, or bad gas, bad tuning. Its probably putting the spark out.

What plugs are in it ?

What fuel ?

When was the last time the fuel filter was replaced ?

Have you checked base timing ?

What computer is in the car ?

davehack
09-26-2005, 03:42 AM
it is standard ecu at the moment. l use ngk plugs they are new and run bp ultimate fuel 98 octane dont know about fuel filter though but am getting it serviced next week and told them to carbon clean the air flow meter to see if that was it mr coils were a bit carbed up but just funny that l only get it on high boost and only in 2 and 3 gear

tyndago
09-26-2005, 11:36 AM
it is standard ecu at the moment. l use ngk plugs they are new and run bp ultimate fuel 98 octane dont know about fuel filter though but am getting it serviced next week and told them to carbon clean the air flow meter to see if that was it mr coils were a bit carbed up but just funny that l only get it on high boost and only in 2 and 3 gear

Which NGK plug ? What is the gap ?

You might have a coil going bad.

How much boost is high boost ?

High boost - 2nd and 3rd gear normally means its putting the spark out. It could be detonation, it could just be way too rich.

davehack
09-26-2005, 06:24 PM
l am having same problem but it is only when l am running 12 psi not when l am running the standard boost anyone got any idea's or is it the same problem

12psi the gap is .8 dont think it is detonating cause there is no pinging they are iridium plugs think it might be cross fire cause coils havent been serviced will let you know. what do you think

tyndago
09-27-2005, 02:20 AM
12psi the gap is .8 dont think it is detonating cause there is no pinging they are iridium plugs think it might be cross fire cause coils havent been serviced will let you know. what do you think

12 psi is not high ....it shouldnt be putting the spark out... It might be a coil or a MAF..... more likely a coil having a bad day under higher load.

But the MAFs can be trickey.

Add your comment to this topic!