1997 Speedometer and gauges


iobrien31
04-01-2005, 11:05 AM
I have started having problems with the Speedometer and gauges in my car.

The speedometer and Tach both show just whatever reading they want and bounce around a lot.

The Fuel gauge shows FULL almost all the time.

The Voltage gauge shows it being up just under the redline value for the voltage.


Oddly enough both the Temperature and Oil Pressure gauges seem to be functioning just fine.

Any ideas on what to look for this?

Smith1000
04-03-2005, 10:32 PM
Probably need to replace the entire gauge cluster. I have 2 '97 LeSabres and have put salvaged gauge clusters in both. One salvaged one I put in had the same problems. Had to take it back and get another. They both work fine now. My oil pressure gauges, temp gauges always worked. The main problem seemed to be with the speedometer and tach. They would bounce around and read erratically. The tach would jump. I would be sitting at a stop light and the speed would read 20 MPH. I replaced the veh. speed sensor on one and it made not difference. The VSS signal goes through the ECU. It's all electronic. The problem is probably in the guage cluster. My odometers would read right even though the speedometer wouldn't.

iobrien31
04-04-2005, 12:22 PM
Probably need to replace the entire gauge cluster. I have 2 '97 LeSabres and have put salvaged gauge clusters in both. One salvaged one I put in had the same problems. Had to take it back and get another. They both work fine now. My oil pressure gauges, temp gauges always worked. The main problem seemed to be with the speedometer and tach. They would bounce around and read erratically. The tach would jump. I would be sitting at a stop light and the speed would read 20 MPH. I replaced the veh. speed sensor on one and it made not difference. The VSS signal goes through the ECU. It's all electronic. The problem is probably in the guage cluster. My odometers would read right even though the speedometer wouldn't.

Yes I do enjoy seeing the gauge bounce up to 80 while I am sitting at a stop light.

Guess it is time to start calling the junkyards and see what I can get.

Smith1000
04-04-2005, 08:15 PM
Yeah, they always ask which one you need and tell you that you need the number off the back of the gauge cluster. You just need the one "with gauges". There is one other type of gauge cluster in the LeSabres that doesn't have a tach or oil pressure guage.

Add your comment to this topic!