1994 Amigo Loses Power Stalls/ Need Diagrams


NetKnockout
03-08-2005, 02:19 PM
1994 Amigo (manual transmission), 80,000 miles.
After driving approximately an hour of highway miles and ONLY when the gas tank is below a quarter tank full, the truck will start to sputter and then lose power, if I push the clutch in, it'll recover, but only for a brief time, this will repeat several times, then the truck stalls. The truck will start right back up with no problem. This has happened on two separate trips (both trips were to the same place). The first time I just thought it needed a bottle of fuel injector cleaner, so I pulled over at the first gas station and gave it one plus a full tank of gas and she, (Red Robin), ran fine. I thought the problem was solved, because it ran fine on that trip as well as a couple more to the same place (2 hours away), until yesterday, when the problem occurred again though this time I had just gone past the gas station, so I was on the highway with no where to pull off, so I nursed the truck for a long time with the problem growing worse and worse. I finally made it to my destination, jumped on line and found an article where someone else was having the same problem and they said it only happened when the gas was low, so I filled my tank up and sure enough it ran fine. I have had the gas at an eighth of a tank or lower and not had any problems as long as I have not been running the truck for a long distance. I did lose my gas cap a few days before the first time it happened but had replaced it before the second time. Any thoughts would be greatly appreciated. Also, does anyone know where I can get a diagram of the fuel system, and/ or repair manuals? Thank-you... Nikki

barteldt
03-14-2005, 01:40 AM
sounds like a fuel filter issue. the diagramsare in the haynes manual

Add your comment to this topic!