How many miles do you have your Isuzu?


Pages : 1 [2] 3 4 5 6

SMOKYHIKER
06-04-2005, 01:01 AM
2001
V6
87,000
Ping,Ping,Ping no matter what I do.
Check engine light-Cleaned EGR after advice from this board.So far light is still out!
Rear brake pads at 87,000. Still on original front pads and rotors but need replacements soon.
S belt
Change my oil at home every 4000-4500.

matt95gsr
06-04-2005, 01:06 PM
1997 "Passport"
3.2 V-6
98,000
timing belt, water pump, starter, rear passenger window regulator, brake pads, mass air flow, gonna pick up new alternator today.

witherer
06-04-2005, 11:40 PM
1994 3.2L V6, 161,000
CV Boots, alternator, re-grease 4x4 hubs, rotors re-faced, Sea Foam treatment for ticking, replaced starter

KurtAZ
06-05-2005, 11:52 PM
1995 Passport

179,659 miles and still going. :)

perry8685
06-16-2005, 12:14 AM
Year:1994

perry8685
06-16-2005, 12:28 AM
Year:1994
Engine:3.2L V6
Mileage:114,500
Major Problems:
Fuel Pump Failure! The reason I consider this a big issue is the fact that I had just replaced the fuel tank due to the fact that someone wedged their car under my rear and crushed it! When this happened the Insurance adjuster decided the pump was fine, which it was but with 105,000 miles on the vehicle who's to say it won't go any day?! I reached 112,000 and it went a couple miles later :banghead: Oh well,
but the real problem is when you have a "HIDDEN???" trailer hitch and the tank has problems dropping below it. Yeah I had to do this with a hydraulic auto jack, a board and my two hands to drop the tank beyond the hitch and reach the fuel pump! Don't forget about the tiny spaces in which you have to reach the little fuel lines and connections in order to do this job.

Anyway,
don't mind my rambling I just have a "short wick" :iceslolan when it comes to fuel tanks and pumps on Isuzu Rodeos with "HIDDEN???" trailer hitches!!!

Hope it never happens to you
Perry

NJFrank
06-16-2005, 07:17 PM
Year: 96
Motor: 3.2
Mileage: 125k

Major Problems: None so far

Minor Problems Past:

Starter Motor
Rear axle seal driver side (while under warrenty)
trans sensor (while under Warrenty)

Current issues (no time to fix)

Passenger side window regulater
4x4 won't engage
Dash Lights not working
Famous valave ticking sound (have to spend more time playing w different filters)

All above seem to minor fixes, just need the time to address them.

D-FOSSE
06-24-2005, 08:07 AM
95
3.2 v6 4x4
120k
excesive cranking to start, reverse problems when in 4x4

bighops2000
06-30-2005, 12:31 AM
JUST TURNED 165K no serious problems. plan on keeping until the wheels fall off

dea2650
07-06-2005, 10:24 AM
Rodeo's are the best:
1995.5 Rodeo 4x4
195,000 miles
My first and only new vehicle. This vehicle has never left me stranded, even when the alternator finally went out at 150,000 it still had enough juice to get me home. Wish I could keep it forever!

Trigggl
07-14-2005, 09:00 AM
Year: 1997
Engine: 2.6L 4cyl
Mileage: around 130K
Any major problems: Had to replace the clutch after around 60K. Bought it at 50K. (used cars :disappoin ) Had to replace the fan clutch at about 75K. Got the timing belt and water pump while I was at it. Electric EGR valve went bad at a price of $150. Rear suspension is very weak. Steering is really loose. Had to replace some dash lights. Can a brother get a second cup holder and rear speaker cabinets big enough for 6x9's?! How about 5x7's? My escort had bigger speakers.

hazegrey
07-15-2005, 04:30 PM
Miles: 99,500

Had valve cover gaskets replaced at 65,000 (still leaks go figure) 3 alternators and 2 sets of brakes. Timing beat tensioner is going out as well as the carrier bearing but no major problems yet.

cubigman
07-31-2005, 07:08 PM
1993 Rodeo V6 4wd
228,000
No major problems
It just keep on ticking!!!

shakagg
07-31-2005, 09:58 PM
1999 Rodeo
V6 3.2
151,000

No major problems.

Has the usual fuel sending unit failure and oil consumption complaint.

Taking it in next week for timing belt, water pump and tensioner swap.

97Rodeo
08-09-2005, 05:38 PM
1997
3.2L
214,000

Major tune-ups as required, tires, brakes.
No major problems!

campo
08-09-2005, 10:57 PM
2000 LSE
70k
No tick
Runs good
Needs new shoes again, looking at Kumho's

BULLITTR6
08-16-2005, 01:41 AM
Year: 1993
Engine: 3.2 V6
Mileage: 183,000+
Any major problems: Just purchased. New O2 sensor, shocks, fluids, general maintenance items. Power windows need drivers switch pack and motors for 3 of the 4 windows. Need VSS as there is no speedo indication.

smillez_tricky67
08-24-2005, 12:08 AM
Year: 2000
Engine: 3.2 V6
Mileage: 120,000
Any major problems,

Yep, Blown seal on 4x4 transfer case at around 70,000 miles. Rear brake system failed at 80,000. Power brake booster failed. #2 spark plug blew out of hole when EGR Valve failed at 120,000. Making me have to pull the head and repair the threads. In doing that I decieded to do both heads so I would have the same problem again.

Paid almost $18,000 for an LS and the car only blue books for $6,000. Really lame. Never again will I go thru this crap

mapua82
08-31-2005, 12:03 PM
1999 Rodeo 3.2 V6 LSE

@40,000
Changed ATF

@45,000
Changed air filter

@54,000
Changed all shocks

@54,000
Changed drive belt pulley & drive belt
Changed PCV

@60,000 Mi:
Changed Fuel Sending Unit
Changed IMG
Cleaned EGR valve
Changed ATF
Changed fuel filter

@65,000
Changed all tires

Present problem:
noise in the pulley @
magnetic clutch assembly

malgieri4
09-13-2005, 01:29 PM
Year: 2001
Engine: 3.2 V6
Mileage: 75,000
Any major problems,Trans leak

GHD1959
09-15-2005, 09:16 AM
1997 Isuzu Rodeo 2.6 151,000 Replaced water pump, thermostat, belts, on second set of tires, first set changed at 103,000, power steering hose, and shocks. I still have original brakes, clutch, Timing belt. Good truck.

surferfletch
09-18-2005, 07:25 PM
Year: 2000
Engine: 3.2 V6
Mileage: 120,000
Any major problems,

Yep, Blown seal on 4x4 transfer case at around 70,000 miles. Rear brake system failed at 80,000. Power brake booster failed. #2 spark plug blew out of hole when EGR Valve failed at 120,000. Making me have to pull the head and repair the threads. In doing that I decieded to do both heads so I would have the same problem again.

<b>Paid almost $18,000 for an LS and the car only blue books for $6,000.<B/> Really lame. Never again will I go thru this crap

Sorry you had such a bad experience with your rig smillez. I got my LS for about $17K when it was 2 years old, and it has been the most reliable car I have ever owned, aside from my '74 VW Bug. It surprises me they don't hold their value better.

php
09-20-2005, 10:26 AM
Year: 1993
Eng: 3.2L V6 4X4
Miles: 130,000

Problems: It had a short in the lighting system when I bought it at 112,000 miles. Fixed those and it ran great for a year. Starter went out at 123,000. Real pain to replace. Now at 130,000, it doesn't run well at all. Have replaced plugs, wires, Ignition control module, crank position sensor, MAP sensor, ECM, O2 sensor and it still isn't running good during acceleration.

Ramblin Fever
09-20-2005, 10:10 PM
1995.5
3.2L V6 4x4
99K

Don't know squat bout past history, just bought it. But I do know it runs, sounds excellent, very clean mechanically.

Dealership did have to install new outer CV Boots, and new battery will go in this weekend.

Transmission gear shift linkage "may" be off, not sure yet.

Has a bit of rust on tailgate; muffler's goin out.

sickstringslv
10-05-2005, 03:09 AM
Mom & Dads 1999 4wd at 70,000 not even a lamp burned out yet,just recently replaced original tires. Based on their experience and driving theirs I just bought a 2004 and can't get over how great it is.
If my avatar shows my Jimmy please don't be offended as I have certainly moved on to a higher class :iceslolan

rfowler1
10-20-2005, 07:34 AM
1994 Rodeo
3.2L V-6 with 5 speed trans
154,000 miles
Timing belt & water pump at 65K, two sets of brakes, three sets of tires, 1 clutch at 72K, crossover exhaust pipe at 100K, oxygen sensor at 110K and catalytic convertor at 111K. This thing is built like a tank in the suspension, engine and body! My 2000 Rodeo rides a lot better though. :)

toy_tun
10-20-2005, 02:21 PM
1999
3.2 V6
86k
I just purchased this used and had the CEL come on. Had a loose vacuum line on the PVC valve, otherwise very happy with current condition.

toy_tun
10-20-2005, 02:24 PM
Year: 2001
Engine: 3.2 V6
Mileage: 75,000
Any major problems,Trans leak


I just discovered a very slow leak but quite sure where it is. It appears to be around the screws but need to investigate further. What about your?

Teile
10-23-2005, 03:13 PM
1993
3.2 v6
139500
Other than my gas gauge not working and the back driver side door being jammer car runs like a dream.

RPW
10-24-2005, 05:09 PM
1994 Isuzu Rodeo 215,000K
V6, Std 5 spd w/air

What's been replaced

Harmonic balancer at 83K

3 clutchs ($800 each)

1 radiator at 96K (plastic tank started leaking ... replace with metal rad.)

A/C compressor at 105K (clutch failed .. surface wore away)

2 timing belts - 2 water pumps (1st at 113K and 2nd @ 212K .. was leaking at change)

2 alternators (one in 1999 at 100K) (one now)

1 transmission ...Junk Yard replacement $700 installed @ 140K (rear seal leaked all the 30 wt sae oil out over a period of time)

1 upper and lower ball joint at 212K driver's side.

Wouldn't pass emissions... fuel system wouldn't pressurize. Fixed by dropping tank and tightening the screws that hold the pump in the tank.

Spark plug wires go bad every 40-50K ... engine starts to miss when you bog the engine. Gets worse until you change the wires. Autozone life time warranty is a good thing :biggrin:

Had one set of brakes ... were change at 194K ... honest ... ceramic really does go that long.

All the little water hoses on the top of the engine were leaking at 200K and were replaced. You have to remove the top half of intake manifold to get to the hoses that are in the rear and under it. Heater core is plastic and the fittings where the hoses attach at the firewall will and did break off. Careful :mad:

Needs paint now and I am seriously considering doing it because I think this thing will last forever.

RPW
10-24-2005, 05:16 PM
Forgot one more thing. Wouldn't pass emissions because the tank wouldn't pressurize. Dropped the tank and tightened the six phillips screws on the top of the tank that keeps the fuel pump in the tank. That sealed the leak

RPW
10-24-2005, 05:26 PM
Spark plug wires go bad every 40K ... engine starts to miss when you bog the engine. Gets worse and worse until you change the wires. Bought from Autozone and get a free set every time it starts.

Had one set of brakes ... were change at 194K ... honest ... ceramic really does go that long.

Needs paint now and I am seriously considering doing it because I think this thing will last forever.

Ramblin Fever
10-24-2005, 11:45 PM
WOW! :thumbsup: :bananasmi
It's good to see all of these.

gearshifter
10-27-2005, 10:13 AM
91
v6
23000k

rodeo_chic
11-03-2005, 02:25 PM
Year: 2000
Engine: 3.2 V6
Mileage: 45,500
Any major problems:
the dreaded fsu is being fixed as we speak as well as the intermittent wiper problem. Starter was replaced last week.

Other than that I'm in love with her. I'll get some pics as soon as I get her out of the shop. :)

micu98
11-05-2005, 02:43 PM
1998 With 199550 Miles, Routine Maintenance Done, Changes Timing Belt, Water Pump, Alternator

brielly
11-11-2005, 02:45 PM
96 passport
3.2 113,000 miles
Replaced timing belt @ 80,000
Starter @ 76,000 under warranty
Alternator 100,000 1st replacement was bad out of the box-grrrr
replaced all cv boots @ 110,000
Cleaner egr @ 111,000
She's been a reliable DD since I purchased her at 39,000 miles
Valve cover gaskets have had a slow leak the whole time and will need repacling soon.

Gizmo42
11-11-2005, 05:11 PM
Year: 1999
Engine: 3.2
Mileage: 89000

Just bought it in september. But can tell the previous owners didnt beleive in maintenance. Since I've owned it I have...

Replaced all ball joints
Replaced front hub bearings (something was loose, wasnt sure if bearings or bj's so did all)
Turned front rotors and new pads
Replaced outter CV boots
Replaced FSU
Clean EGR
Replaced fuel filter
Replacing front sway bar end links this weekend (one fell apart while doing the other front end work)
Removed ghetto hitch reciever that was welded to the frame and installed the right one
New tires
New shocks (sensa tracs :iceslolan)
Changed front and rear diff fluids (had never been done)
Put a steel rear diff cover on
Changed trans and xfer case fluids (never done either)
Replaced serpentine belt
Clutch, timing belt, and water pump were replaced by the person I bought it from the week before I bought it
Now need to replace wiper relays, do rear brakes, wire trailer lights, rewire accessory outlets so they will work without the key, mount and wire my inverter, and grease drive shaft splines.. think I'll be done for a while then :rolleyes:

surferfletch
11-11-2005, 08:22 PM
All the little water hoses on the top of the engine were leaking at 200K and were replaced. You have to remove the top half of intake manifold to get to the hoses that are in the rear and under it. Heater core is plastic and the fittings where the hoses attach at the firewall will and did break off. Careful :mad:



PITA to track down and fix that leak. This is the only mention of this problem in 7 pages...

ferretjoe
11-21-2005, 01:00 PM
1995 3.2, 150k+, 3rd transmission (4l30e) :banghead:

SR20Pilot
11-28-2005, 06:47 PM
'94 Passport
3.2 w/210k. Burns a little oil (.5 qt every 3k).
Wife did custom front end work with the help of the rear of a SantaFe. ;)

rambo1214
12-02-2005, 10:55 AM
Year:1999
Engine: 2.2L
Mileage: 107K
Any major problems: CEL with code P0342 Camshaft Position Sensor low voltage input. Intermittent happens about once or twice in two weeks time then it turns its self off in 6 starts.

EastMonsoon
12-03-2005, 02:57 PM
Year:2001
Engine:V6
Mileage:62100
Any major problems:None except two accidents before I bought it :banghead:

surferfletch
12-03-2005, 03:48 PM
Year:1999
Engine: 2.2L
Mileage: 107K
Any major problems: CEL with code P0342 Camshaft Position Sensor low voltage input. Intermittent happens about once or twice in two weeks time then it turns its self off in 6 starts.

How old is your timing belt?

rambo1214
12-03-2005, 06:15 PM
that is going to be the first thing I replace since that last time I know it was replaced was in dec 2001 at somewhere around 20K

rmargio
12-09-2005, 06:48 PM
Year:2000
Engine:3.2 v 6
Mileage:192000
Any major problems:None

:biggrin:

surferfletch
12-09-2005, 07:43 PM
1995 3.2, 150k+, 3rd transmission (4l30e) :banghead:
How did the first 2 go? Do you tow?

erock3000
12-18-2005, 01:08 AM
i love my rodeo 150.000 miles on this baby dont want another auto and if i do its going to be a rodeo just change the oil and everything else your supposted to do and the girl will last forever and wont let u down . wish all girls where like that.

surferfletch
12-20-2005, 11:31 PM
1995 3.2, 150k+, 3rd transmission (4l30e) :banghead:
Curious to know what happened to the first 2 trannies. How 'bout letting this post hang out? Sure the info would be helpful...

2001 r_o_deo
12-31-2005, 01:42 PM
I bought it new, 2001 Rodeo 2WD S 4CYL 2.2 65k miles or 45k if you subtract the extra miles the oddometer has been adding in, still not fixed, that's another story read below.

started with check engine lite, autozone read the code as camshaft position sensor low input. Took it to dealer, had to replace shorting out sensor......over $500!! Not covered under warranty!! They gave me the old part. I later searched the web and cannot yet find anyone that carries the part so that I can compare prices. I have a shop manual and I still can't even figure out where this part is. Anyone have anything on this at all?

I like the truck but it has had problems from day one.

1.)Windsheild replaced for warped uneven blurry glass (check yours) all the rodeos on the lot had bad windsheilds. Ordered and replaced at a later date.
2.)A/C wouldn't work (bad sensor).
3.)Rear cup holder parts messed up.
All this found the first day!
4.) Then the Oddometer nightmare! It's counting more miles than traveled! Also reading mph too fast. Check yours! Had the whole cluster replaced, still not fixed! Is this how they get out of the 10yr or 100k mile warranty??
5.)Pinging noises come and go.
6.)All kinds of rattle noises on idle.....dealer said it was OK.
7.)replaced timing belt and tensioner, tech found back of water pump came off and was scrapping timing belt! Replaced pump too.
8.)What's with the dip stick for the oil?? Everyone that reads it gives me a different answer! Is the full mark the top bead or the bottom? I gave up and started changing my own oil and putting in what the specs say, everyone else has been overfilling it. Or I'm underfilling it.
9.)Asked how much they give me to trade it in, a mere $3500.

Should I keep it? What should I do? How much more could go wrong?

rambo1214
12-31-2005, 02:51 PM
[QUOTE=2001 r_o_deo]I bought it new, 2001 Rodeo 2WD S 4CYL 2.2 65k miles or 45k if you subtract the extra miles the oddometer has been adding in, still not fixed, that's another story read below.

started with check engine lite, autozone read the code as camshaft position sensor low input. Took it to dealer, had to replace shorting out sensor......over $500!! Not covered under warranty!! They gave me the old part. I later searched the web and cannot yet find anyone that carries the part so that I can compare prices. I have a shop manual and I still can't even figure out where this part is. Anyone have anything on this at all? Camshaft positioning sensor is located under the timing blet cover on the front of the engine up at the top between the two timing sprokets. if you want to see the electronic hookup take off the black cover on the top of your engine that covers your spark plugs. It will be the only thing that has a electronic connector closest to the front of the engine.
Autozone for $168 has to be ordered
AC DELCO for $103 online have to find someone to order the part for you
I like my 99 Isuzu Rodeo I dont think I'll let it go till it cant be fixed.

mewatts
01-02-2006, 08:25 PM
1998
3.2 v6 4x4
109500

major repairs

tranny rebuilt @ 89k
speed sensor (not really major but did scare the shit out of me when it started bucking on the hwy.)
timing belt + tensioners @ 89k
power steering pump

all in all its been a pretty good vehicle

bishop242
01-05-2006, 01:43 PM
2000 Rodeo LS - 115,500 miles
Purchased w/ 110,000 on odometer.
New BFG All Terrain T/A rubber
New Monroe SensaTracs
Switched to Synthetic oil
Changed tranny fluid and filter
Repacked wheel bearings
4 wheel allignment
Cleaned EGR and pcv
New plugs - NGK NON Platinum (working great for me)
Sirius receiver
Slowly taking care of the long term maint. items so they dont creep up on me!
Has been great except for the dreaded FSU problem and the slip yolk needed to be greased.
The dealership did the yolk for me at no cost and has offered to sell me a new FSU (parts only) for $32.00. Just waiting for the motivation and a free afternoon to install it.
:smile:
1991 Trooper V6 110,000
New belts, plugs, spark plug wires, hoses
Blown headgasket @ 105,000.... "Used one of the headgasket in a bottle" treatments and it has been running better than ever for the last 5000 miles!
I can't seem to hurt this beast no matter what I put it through.
Rubber boots on front end are starting to self destruct

andy81563
01-14-2006, 12:40 PM
[QUOTE=amigo-2k]I thought I would start this trend to watch our members Rodeo's rack up the miles over the years.

Here is the format to use:
Year:
Engine:
Mileage:
Any major problems:

1999 Passport
3.2l, V6
101,000
No problems except for EGR.

nykolos
01-22-2006, 03:59 AM
Year: 2000
Engine: 3.2 DOHC
Mileage: 77,000
Any major problems:

Spun rod bearing, replaced crank, complete engine overhaul at 74,000
Fried all main and rod bearings, Replaced crank and bearing again @ 74,800
Oil pump intermittantly failed, replaced it again ( both factory)
Water pump leaked, replaced 2 of those.
Fried 2 air conditioning compressors
A/C fan switch sometimes wont work, hit the dash a few times and it works!
Constantly pings, no matter what Octane you use.

I rebuilt this engine myself, cause of the bad cranks was low oil pressure and a bad pump, it unbelievable factory specs only call for 10 lbs of pressure @ 500rpm, no wonder we have so many cases of spun rod bearings, if your using a lower viscosity oil like 5/30 or 0/30 or adding seafoam, the pressure drops even more, lower viscosity = lower pressure. Seems its always the #1 or #2 rod bearing, which are the last rod journals to recieve oil. Since Isuzu failed to include a oil pressure gauge, add one yourself and check the oil frequently, since these engines like to burn oil fast. What is good oil pressure at idle? 30 to 45 lbs


Here is another post with Isuzu owners mileage:



I thought I would start this trend to watch our members Rodeo's rack up the miles over the years.

Here is the format to use:
Year:
Engine:
Mileage:
Any major problems:


Here is another post with Isuzu owners mileage:

http://www.4x4wire.com/forums/showflat.php?Cat=&Number=135479&page=1&view=collapsed&sb=5&o=1&fpart=&vc=1&PHPSESSID=

patjo
01-23-2006, 10:44 PM
1996
3.2
156k

Chiron33
01-27-2006, 02:17 PM
97 3.2l 4wd manual

105000

I am about to put a new starter in... other than that, nothin... I even got rid of the infamous ticking!

directory
01-27-2006, 03:48 PM
Year: 1999 honda passport
Engine: 3.2L v6
Mileage: 67,xxx
Any major problems:

just replace the IMG and throttle body gasket.

....and air filter

srfrjames24
01-29-2006, 03:38 PM
2000 rodeo
3.2L V6
97k miles
just replaced all 4 shocks and belt but no major problems. runs great!

Mirock
02-01-2006, 07:39 AM
1999 Rodeo Ls 4x4
89000 miles

No major problems so far .Great truck.

Add your comment to this topic!