Heater Fan Motor only 2 speeds


pelermon
02-23-2005, 05:00 PM
I just bought a nice 96 2dr /Auto/ 4x4/ Tracker LSI.

The heater fan switch has off and 4 speeds.
The heater fan only works on 3 speed and 4 speed, which is too much air and loud, all the time.
Speeds 1 and 2 turn the fan off.
Any ideas on what is wrong here?

1995 geo tracker
02-24-2005, 10:29 AM
sounds like you need a new fan switch

Roadkill_Ak_47
02-27-2005, 10:09 PM
i've got the same type problem, my connection to the blower motor was loose and becouse speed 1 and 2 dont have enuff energy to make the jump accross what ever gap and turn the fan it dose nothing

pelermon
02-28-2005, 07:06 AM
i've got the same type problem, my connection to the blower motor was loose and becouse speed 1 and 2 dont have enuff energy to make the jump accross what ever gap and turn the fan it dose nothing

Did a better connection fix the problem ?

Roadkill_Ak_47
05-11-2005, 01:24 AM
i havent gotten around to fixing the blower motor couse the wind ( with some help of my girlfriend damaging the velcrow stitching) riped off the hole rear of the soft top i have, i managed to sew most of it back together with fishing line it seems to be holding well, any way i've tried to take the blower motor out but some of the bolts are hard to get to and my tools are limited ill have to get back to you guys on this

shortdog
06-16-2005, 03:10 PM
I just bought a nice 96 2dr /Auto/ 4x4/ Tracker LSI.

The heater fan switch has off and 4 speeds.
The heater fan only works on 3 speed and 4 speed, which is too much air and loud, all the time.
Speeds 1 and 2 turn the fan off.
Any ideas on what is wrong here?
there is an electrical connection under the glove box, it is small and it has coils i changed that and got all the speeds back

Add your comment to this topic!