2001 Explorer Sport rear turn and brake light issue.


mlh232
02-21-2005, 04:50 PM
My son is having a problem with the rear turn signals and side brake lights. Sometimes they work but most of the time they don't. Is there a wiring harness connection somewhere in that line that may be loose which is causing this problem. The center brake light works all the time.

B33p3r
02-21-2005, 07:31 PM
I'd check the bulbs first. Possibly have one with loose filaments sometimes grounding the cicuit or sometimes not. Easiest check to start with.

Bronco2
02-21-2005, 07:53 PM
You probably have a bad turn signal switch. The rear brake lites and turn signals are run thru the turn signal switch,the center brake lite is powered thru the brake lite switch.

jerzeyjosh
03-14-2005, 09:19 PM
Any luck?? I am having very similar problem. My rear driver's side turn signal and brake light do not work. I replaced the flasher relay and the turn signal switch, that didn't help. The bulb and bulb socket are good (tested it on the passenger side light). Using a voltmeter I found the signal is NOT getting to the tail light, but it is leaving the signal switch mounted on the steering column. I ran a temporary wire that will operate the turn signal for now, but the brake light is still not working. Any ideas??

mlh232
03-15-2005, 12:25 AM
Any luck?? I am having very similar problem. My rear driver's side turn signal and brake light do not work. I replaced the flasher relay and the turn signal switch, that didn't help. The bulb and bulb socket are good (tested it on the passenger side light). Using a voltmeter I found the signal is NOT getting to the tail light, but it is leaving the signal switch mounted on the steering column. I ran a temporary wire that will operate the turn signal for now, but the brake light is still not working. Any ideas??


Yes, the problem was solved. Had to take it to a Ford dealership. It was the multi switch conncetor for the turn siganl / brake lights. The cost was about $200.00 for the repair. Thank God for extended service warranties, only had to pay a $50.00 deductible

Add your comment to this topic!