2 speed sensors? 99sport


badthumper
02-15-2005, 06:11 PM
tranny not shifting right.... tranny shop changed one sensor but didnt fix it havent had time to take it back yet.
on hwy truck wont shift into O.D. untill take foot off gas. then seems to jump O.D and go into the next speed LOCK UP? just wondering where these sensors are and how much? thanks.

:evillol:

theFREAKnasty82
02-16-2005, 04:46 AM
you have two sensors, input and output. The input speed sensor is on the drivers side of the transmission closest to the bellhousing. The output speed sensor is on the back by the tailshaft. Theoretically, those sensors aren't interchangable, but if some yahoo who doesn't know his left hand from his right hand mixed them up, you could run into the problems that you are currently having.

badthumper
02-16-2005, 06:43 AM
thanks NASTY... will be discussing this with the Yahoo

scoutinkeith
02-16-2005, 02:36 PM
well, I think that's partly correct. my truck is a 99 also, but it's not a sport(which I think is just an appearance package), and I have one speed sensor in the trans, but the other speed sensor is on the top of the rear axle, and also used for the rear abs.
if the rear sensor goes bad, you'll loose your spedo below 20 or 25 MPH, and your "abs" and "break" lights on the dash will come on.
if your spedo is working fine, and the trans shop changed the one in the trans, I'd think that the problem is something else. it might be a good idea to have the TV cable adjustment checked, as well as the TPS voltage.

theFREAKnasty82
02-16-2005, 11:09 PM
also have them check to make sure that you don't have your speed sensor wire (output) not shorting itself out on a bolt or any other metal component; that could also give you shifting issues.

Add your comment to this topic!