Our Community is 705,000 Strong. Join Us.


Twilight Sentinel does not work


rmcilvaine
01-15-2005, 09:38 PM
Hi,

Te Twilight Sentinel on my 1995 Aurora does not work. The dial rotates but the lights do not respond.

Anybody have any ideas?

KillerKeller_jr
02-15-2005, 05:50 PM
Hi,

Te Twilight Sentinel on my 1995 Aurora does not work. The dial rotates but the lights do not respond.

Anybody have any ideas?

My car is having the same issue. I turn on the twilight sentinel and then while I am driving around, poof my lights turn off. I have had this car for 2 years now and it did not do this before and no its not from bright lights. It just seems as if the sensor is or has gone bad. Anyone else have this issue? Also it does not matter how the sentinel is adjusted, lights just come on or shut off as they feel. Please someone give some input on this issue.

Thanks

KillerKeller_jr
02-20-2005, 10:47 AM
***BUMP***

Any Ideas here....

Anyone at all have an idea....

Throw us a bone here....

Thanks

KillerKeller_jr
02-20-2005, 11:22 AM
Found this in another post since no one here wants to really help. Also try replacing your Twilight Sentinel, sounds like yours could be broken possible, cheat part I believe. I am going to try the following for my problem of the lights going off and on when I travel down the road. Update me if you solve your issue.

Yes I too can confirm that the multifunction headlight switch is what makes the headlights randomly flash back on and off after the car is turned off. The relays inside the Lamp Control Module box located under the left side of the dash will also make a random click noise that coincides with the random flashing of the lights. In my case and most others, you will find that the Lamp Control Module is not the problem and niether is the twilight sentinel adjustment control. Again, the multifunction switch seems to be the common culprit. I did a search here and on a couple of the other Aurora forums and everyone seemed to cure their flashing lights/stuck on syndrome by replacing the multifunction switch which cost over $500 for a dealer to do it. I also found a few posts by Hammen and others that made reference to too much grease in the rotating part of the switch where the contacts are housed. I found another post about using contact cleaner with good results and this is what I did to cure my problem today.

Pardon me for being longwinded but here is how I saved over $500 and you can do it too. You will need to gain access to the rotating contact part of the switch that is hidden under the steering wheel covers but you will not have to remove the switch in order to clean it. You will need to buy a can of electrical contact cleaner and a can of compressed air like you use for keyboards. Both can be had at Radio Shack and both come with the red extension tube that fits the spray nozzle. First move the seat all the way back, then disconnect the battery, remove the sound deadeners, remove the two 10mm bolts at bottom of knee bolster, use your fingertips to pry the sentinel/dimmer assembly and trunk/fuel door release assembly from dash (leave harnesses connected and let dangle) to expose the remaining two 10mm bolts securing knee bolster, remove knee bolster, remove 10 amp fuse for Air Bag, disconnect SIR (air bag) yellow connector at lower left corner behind ins panel, tilt wheel up, use 3/16 or 5mm nutdriver to remove 3 screws securing steering wheel top cover (note that 1 screw is accessed thru the opening for the tilt lever while the other 2 are located on either side of the column closest to the lense/guages), remove 3 more of the same small tapping screws securing the lower steering wheel cover to column, remove black ring of text around ignition lock by pulling straight out, upper and lower covers can now be unsnapped and removed. With your left ear against the mirror control looking just forward of where the stalk goes to the column, you will see 5 tiny holes in a semi-circular pattern. When turning the headlamp switch you can see the contacts moving from hole to hole. Spray contact cleaner in the holes and immediately follow up with the compressed air can to flush out the contact cleaner. Move the headlamp switch rapidly thru all the detents and repeat several times with the contact cleaner followed by several bursts of compressed air to flush out the excess cleaner and dry. When finished, wait 30 minutes to make sure contacts are thoroughly dry then reconnect battery and test. Hopefully all is well and like me you just saved some major $

Joner54
09-04-2005, 04:09 PM
My car is having the same issue. I turn on the twilight sentinel and then while I am driving around, poof my lights turn off. I have had this car for 2 years now and it did not do this before and no its not from bright lights. It just seems as if the sensor is or has gone bad. Anyone else have this issue? Also it does not matter how the sentinel is adjusted, lights just come on or shut off as they feel. Please someone give some input on this issue.

Thanks
Hi-I'm new to this forum and I tried asking this same question about our 1998 Aurora yesterday. Someone was "kind" enough to reply with nothing more than "you can't ask car questions on this forum". Now I'm confused but I'm going to try again this way. Our dash lights-ac and radio as well, go out about 5p.m each day and don't come back on until around 9.a.m Doesn't matter where the sentinel switch is adjusted to either. Have you found a solution and if so was it costly? We wondered if it was out sensor and heard it would be expensive to replace. On a cloudy day we have no dash lights either. Thanks to anyone kind enough to offer some help! Joner54

KillerKeller_jr
09-08-2005, 09:52 PM
Does anyone here have any ideas as to what can be going on here. I have a similar problem only now it seems the sensor does not work at all. I think I will just see what a GM mechanic thinks I should replace. I think the sensor is about $30. If I find anything out Joner54 I will post it here for you.

Joner54
09-09-2005, 07:12 AM
Hi-I'm new to this forum and I tried asking this same question about our 1998 Aurora yesterday. Someone was "kind" enough to reply with nothing more than "you can't ask car questions on this forum". Now I'm confused but I'm going to try again this way. Our dash lights-ac and radio as well, go out about 5p.m each day and don't come back on until around 9.a.m Doesn't matter where the sentinel switch is adjusted to either. Have you found a solution and if so was it costly? We wondered if it was out sensor and heard it would be expensive to replace. On a cloudy day we have no dash lights either. Thanks to anyone kind enough to offer some help! Joner54


Thanks KillerKellerjr. I'll keep my eye out for your response. I hope you find a solution-doesn't appear that anyone else has yet! Good Luck-I hope you're right about the cost of that sensor! Joner54

Joner54
05-10-2006, 01:33 PM
I asked this question once before but I've still got the same problem. Our dash lights stop working around 5 O'clock EVERYDAY on our 1998 Aurora. We've tried ALL of the suggestions given and nothing has worked. I'm wondering if anyone else with this problem has a remote starter on their car. We're wondering if that may be causing the problem. We didn't have the problem before but this didn't happen as soon as it was put on but it certainly has happened since then. Any ideas? joner54

Add your comment to this topic!