Our Community is 705,000 Strong. Join Us.


1995 Jeep Grand Cherokee Laredo won't start


customer
01-01-2005, 02:23 AM
My 1995 jeep won't start, It ran great and I came back to start it after 10 minutes it fired up and when I put it in reverse it stalled and will not start or fire engine light comes on with key on all dash indicator ights come on normal and go off normal while cranking engine. any Ideas on the problem??

Cam7
01-01-2005, 04:13 AM
Check to see if it is getting spark and fuel. My first guess is the Crank Shaft Position Sensor hard to tell without checking for fuel and to see if it is getting spark.

kjmi64
01-01-2005, 03:42 PM
Cam7 is right try checking fuel pressure at the fuel rail valve with a simple fuel pressure gauge (most auto part stores for $30-$40).
If you have good fuel pressure, which I think should read around 245KPA
(check the service manual), then go for a spark check on one of the spark plugs. If the plugs are wet replace them before retrying to start.

dksob81
01-01-2005, 07:08 PM
does the CHECK ENGINE light come on when you turn the key on, sorry I knwo you mentioned this in your first post but I did not under stand if you were saying it does or does not come on.

customer
01-01-2005, 11:46 PM
No spark from coil or spark plugs engine light works as it should the spark plugs were wet and colored orange smelled of gas,fuel pressure ok..code 11 still presant.could security be a cause? crankshaft sensor test ok.new camshaft sensor installed. battery ok.fuses and relays ok.computer vehicle display doesnot register passenger door open on screen all other funtions work on display,all dash service lights work and reset ok. moisture found in connecting wires to coil, coil wire to distributor had to be cleaned on distributor side "cap" will purchase new wires,coil, and plugs in AM..

Dale Aeppli
01-02-2005, 10:54 AM
No spark from coil or spark plugs engine light works as it should the spark plugs were wet and colored orange smelled of gas,fuel pressure ok..code 11 still presant.could security be a cause? crankshaft sensor test ok.new camshaft sensor installed. battery ok.fuses and relays ok.computer vehicle display doesnot register passenger door open on screen all other funtions work on display,all dash service lights work and reset ok. moisture found in connecting wires to coil, coil wire to distributor had to be cleaned on distributor side "cap" will purchase new wires,coil, and plugs in AM..



You said new camshaft sensor was installed, do you mean the one inside distributor. Dale jeepman600@sbcglobal.net

customer
01-08-2005, 03:02 AM
You said new camshaft sensor was installed, do you mean the one inside distributor. Dale jeepman600@sbcglobal.net

Yes I replaced the camshaft sensor in the distributor and now I am going to replace crankshaft sensor on bell housing, already while I was at it replaced spark plugs,spark plug wires,new coil,new distributor cap and rotor also inspected all wires connecting to all of these sensors and hopefully after I install the crankshaft sensor this rig will come alive again..I read where a grentleman replaced three crankshaft sensors before he finally replaced it with a brand name (i don't remember brand name) anyway this was all done before his rig started do to not having enough power or what ever it is this sensor does to keep your rig running have you ever heard of that? reason I ask is if this doesn't work (replacing crankshaft sensor) should I look into this being a problem?? thanks everyone for your help when and if I get this Jeep a going I will let you know thanks again Paul..

dksob81
01-08-2005, 09:53 AM
brand name was eichlin, I think thats how it's spelled, he was using borge warner brand before that with NO GO

customer
01-11-2005, 02:52 AM
Well it is great news after installing everything I could for my ignition to work in harmony with all of it's other components the last part I put in was the crankshaft sensor and wala she runs like a top, thank you for all your help and ideas I got a great education on the workings of my Jeep and what to help others with if they experience similar problems with there Jeep..Again thanks loads..Paul :grinyes:

Add your comment to this topic!