Page updated on 10-23-2017

what is wrong with my brakes???


a1waytrip
12-30-2004, 01:50 PM
ok, i just had both my rear caliper's ceaz up on me, so i replaced both of them, and the rotor's, with drilled and slotted ones, but now the e-brake is like barly working. i've tried adjusting it with the nut under the e-brake handle, but it's the same thing. i can yank on the e-brake, and it will come very slowly to a halt. i don't know what the problem is, but even my regular brakes arn't working the best. but i just got home from the salvage yard, and i touch the rotor, to see if the brakes were dragging, and i nearly burnt my fingers off, but only on one wheel, the back driverside. so, i don't really know what to do now. when i changed the caliper's i bled them and everything. if there is any ideas out there, i would appriciate it, oh yea my car is a 94 pgt. thanks
tom

a1waytrip
12-30-2004, 02:17 PM
oh yea, my brake lightn is on... and ideas?

jtecj
12-30-2004, 08:22 PM
Try following your break lines from your master cylinder to the calipers...cant guarantee anything but I am willing to bet the problem is with your master cylinder or the break booster. check the break fluid and make sure its not too dark cause it will absoarb moisture and when it does that you have a problem because durring hot weather it will heat up and expand when that happens your lines will crack. try to pump up your breaks and tell us exactly what happens if you pump it three times than press it in again does it go back to the floor? If it does it is a sign of a bad seal in the master cylinder and that would be my bet but there are a lot of reasons as to why this could be hapenning.

a1waytrip
01-02-2005, 09:04 PM
nevermind, im an idiot, my brake fluid was low. haha, ahh, i feel like such an idiot, after i bled my lines when i installed the calipers, i forgot to fill it up. oh well, thanks for trying to help me though.

Add your comment to this topic!