Page updated on 07-23-2018

Accord 92' Speedomotor doesnt work along with seatbelt light!!!


HondaRacer574
12-27-2004, 12:10 AM
I have a 1992 honda accord and for christmas i got indiglo lights to go over my gauges. WIll i thought this was going to be easy but it seems not to be. I removed my cluster out of my car and installed the indiglo lights. I put the speedometer and all back in and started the car. Just to make sure that the gauges still worked. I put it in gear, and what do you know everything worked but the speedometer. I removed it again and pluged it up again. But not sitting it in the harnessed and i noticed that the seatbelt light is not coming on either. Will It did and then i put it in the harness and the seatbelt light didnt work. The speedometer didnt work either way. I think theres a short in the seatbelt light, but i dont know what to say about the speedometer. I forgot to check the fuse but if everything else works y would it go out. Why would it blow anyways. Any Help please let me know. Home Bound Until Fixed.

00accord44
12-27-2004, 12:15 AM
My friend has a 94 civic that had a similar problem. Only the speedo and tach didn't work. He just changed the dash fuse and voila! Try it. If it doesn't work, you're only down like $1 for the fuse :sunglasse :2cents:

mpumas
12-28-2004, 03:28 AM
You probably do not want to hear this, but I know it looks cool to do all these things with the dash lights but you can now probably realize now that it is very easy to introduce problems whenever you take out the dash. The wires are fragile and so are the connectors. There is an old saying==If its not broke, don't fix it.

Add your comment to this topic!