Page updated on 06-21-2018

95 Ram 1500 5.2l Rough/Stalls/Dies


leeharris100
12-25-2004, 04:03 PM
Hi, I have a 1995 Ram 1500 5.2l. The other day I was pulling into my neighborhood, and it started acting like it was chugging for gas, like I was out (I had a fourth of a tank). I turned it off, checked everything, and it seemed to be workin great, so I started it back up, drove it a couple hundred feet, then it dropped down to a very low rpm, and started shaking, and then I coasted into my driveway. The next morning, I tried to drive it to the gas station which was less than 2 miles away, and it died before I got there. It wouldnt start up, so I left it, and came back about an hour later, and had to start it up 3 times before it would idle. I let it idle for about 15 minutes, and it didn't show any bad signs, so I tried driving it home, and it acted like it was chugging for gas again about halfway through, and then stalled near my neighborhood. I was just wondering if you guys would have any advice for me, it would be greatly appreciated.

Thanks!!

BleedDodge
12-25-2004, 07:51 PM
Probably the catalytic converter is clogging up, or it's broken inside and blocking the exhaust.

How many miles on your truck?

BamaDodgenMX
12-25-2004, 08:23 PM
Sounds about right, or may be a clogged fuel filter.

leeharris100
12-27-2004, 02:53 AM
i have about 125k

netmech
12-27-2004, 07:03 PM
could be a lot of things.. take it into a dodge dealership and get a diagnosis... then tell us whats wrong with it.

BleedDodge
12-27-2004, 07:40 PM
That's about the life of a converter. I bet you that's the problem...

danwilliams
12-30-2004, 03:16 PM
When I had fuel injectors go out on mine it was very similar. I'm driving around with one out right now cuz I'm broke and don't have the dough to get a new one, but intermittently it works. B4, i had 1 go out and didn't know what it was. i let it go, but when the 2nd went out, it was rough, but when sitting idling, couldn't tell it. I mistakingly thought it was a bunch of other things including cat. conv. b4 we correctly diagnosed it.

natale8888
01-03-2005, 07:54 PM
Coil Wire,, Bet Ya.

Jigflipper
01-09-2005, 09:58 PM
Fuel pump went bad on my 95 5.2, why do they put it in the tank. Anyway that was my problem.

BleedDodge
01-09-2005, 11:11 PM
They put it in the tank so it scares you so you bring it in and pay someone to do it for you.

netmech
01-09-2005, 11:51 PM
guys.. u know how a pump works ? any kind if pump needs to be submerged in a liquid.. you have to put it in the tank..

BleedDodge
01-10-2005, 12:24 AM
guys.. u know how a pump works ? any kind if pump needs to be submerged in a liquid.. you have to put it in the tank..
Not. I changed the fuel pump on my 1966 Polara in all of fifteen minutes. It's mounted on the side of the block. Same with my 1984 Turismo, mounted on the side of the block.

bryguy24
03-24-2008, 02:47 PM
Did you figure it out! have the same problem with mine 95 1500 5.2. Drive for a while than it loses all power, can not even move. 40 minutes later will run fine but for less time. 115k miles. One mechanic says cat, another says sludge. pls help

Add your comment to this topic!