1993 Corrado Electrical Problems


cbaish
11-30-2004, 10:47 PM
My son has a 1993 VW corrado that suddenly developed a problem the week before he left for the service. When he turns off the ignition the car continues to run as normal. The lights, radio, etc. turn off but the engine continues to run. The car needs to be stalled to stop the engine and the light for the ABS and emergency brake stay on with the key turned off, but as I said the radio, lights and gauges turn off with the key. The battery needs to be disconnected to kill the power to the engine or the two lights stay on as does the engine.
Also the gas gauge stopped working at the same time as this happened.
I have looked for the obvious short at the fuse block and have found nothing. I pulled the key ignition connector to see if the switch was bad it didnít stop the problem.
Is there a relay that may be stuck? My son canít really afford the local dealer ($125.00 hr, 3 hr min.) so I thought I would see if anyone could help. I can do the work if I know what to look for? Help

boschmann
12-01-2004, 03:31 PM
I suspect a bad ignition switch (electrical part).

cbaish
12-01-2004, 10:42 PM
I suspect a bad ignition switch (electrical part).
The switch is the first thing that I thought of so I pulled the connector to the switch and it didn't stop the problem.
Any other ideas? I could use anything that you can think of.

Thanks

boschmann
12-02-2004, 09:06 PM
Try pulling the ECM power supply relay. It's in position #3, that's the second row above the fuses, third from the left.

cbaish
01-12-2005, 10:18 PM
I checked the switch and pulled the relay, the problem didn't stop.

Anyone else have any ideas???

boschmann
01-17-2005, 08:14 PM
Has anyone wired the cooling fan to run all the time?

Add your comment to this topic!