Water leak comming from back of engine


jtopel
10-25-2004, 10:27 AM
I have a water leak in a 1990 4runner (3vze) at the back of the block i called the dealership and they said the headgasket had been done, i noticed this leak because the water is well orange rust colored to be exact my 4runner needs a new radiator but thats kind of self defeating until i fix the leak at the back of the engine any ideas of wha it could be? or any ideas of how to check if its the headgasket, the oil dosent apear to have any water in it,i beleive its comming from above the head but there isnt much clearance between the injector plant and firewall.

thanks,
James

Glina
10-26-2004, 01:42 AM
I had the same problem. Check carefully all hoses that are connected to coolant by-pass outlet witch is situated at the back of the engine under the air intake chamber. I had the coolant leaking from one of these hoses.

Brian R.
10-26-2004, 10:39 PM
Might be a freeze plug leaking. Get a mirror and find the leak.

jtopel
10-28-2004, 10:25 AM
any tips on how to get a visual of the freez plugs or water bypass? i am thinking about pulling off the air intake so i can get a better view of whats going on back there, thanks for your help

Brian R.
10-28-2004, 07:20 PM
Mirror on a stick?

jtopel
10-28-2004, 10:49 PM
I did a mirror on a stick with a flash light, im thinking about takeing it to the stealership and have them look it over its a tiny spot back in there :)

Brian R.
10-29-2004, 12:19 AM
Good luck.

Help4Ruben
08-09-2006, 12:29 PM
I have a water leak in a 1990 4runner (3vze) at the back of the block i called the dealership and they said the headgasket had been done, i noticed this leak because the water is well orange rust colored to be exact my 4runner needs a new radiator but thats kind of self defeating until i fix the leak at the back of the engine any ideas of wha it could be? or any ideas of how to check if its the headgasket, the oil dosent apear to have any water in it,i beleive its comming from above the head but there isnt much clearance between the injector plant and firewall.

thanks,
James

Well it seems that we have the same problem its real hard to see back there it just started leaking yesturday and its been a head ache if anyone could advise it would be great. i went to my local auto zone i got the manual for it but still does not say anything about that particular problem.

Thanks

HelpRuben.

4RUNNER_RIDER
08-12-2006, 01:32 AM
it might of be the U shape hose that is on the by-pass is bad so to remove that just cut that off and get a new one, I think those U hose is not cheap..., they can go to the 20 dollars range, that in the case if you buy it at napa it might be cheaper there, and when you are giong to put the new one in just remember to get the clamp that no need to screw to close, the one that just snap on is much better, it just make work easier next time you replace it again.

Help4Ruben
08-13-2006, 12:04 AM
it might of be the U shape hose that is on the by-pass is bad so to remove that just cut that off and get a new one, I think those U hose is not cheap..., they can go to the 20 dollars range, that in the case if you buy it at napa it might be cheaper there, and when you are giong to put the new one in just remember to get the clamp that no need to screw to close, the one that just snap on is much better, it just make work easier next time you replace it again.

Well thank you very much everything you wrote is exactly what it was i thank you very much. unfortunatly i had fixed it 2 days b4 i read the reply so it took me all day to figure it out i burned my hands arms u name it, but finally i got it. so for the next person with this problem thats the first thing you should check thanx very much. it's crazy how people can help others from your own home. i took it to the mecanic the first thing leave the car i ll check for like 45 bucks i let you know the problem. so i said i got to find out what it is and fix it my self and i did. total was like 20 bucks, hose was 8.99, i had to buy a long plyers. so there you go. for any detail questions in fixing it feel free to ask.

roger84
02-10-2009, 07:47 PM
Well thank you very much everything you wrote is exactly what it was i thank you very much. unfortunatly i had fixed it 2 days b4 i read the reply so it took me all day to figure it out i burned my hands arms u name it, but finally i got it. so for the next person with this problem thats the first thing you should check thanx very much. it's crazy how people can help others from your own home. i took it to the mecanic the first thing leave the car i ll check for like 45 bucks i let you know the problem. so i said i got to find out what it is and fix it my self and i did. total was like 20 bucks, hose was 8.99, i had to buy a long plyers. so there you go. for any detail questions in fixing it feel free to ask.

Help please. I just discovered the same leak on my '95 4runner. I couldn't find the leak so I'm getting ready to take it to a mechanic, but I just read your post...maybe I'll try again? Could you tell me where to look for this hose and how to get to it? From the top or underneath the car?

much thanks

cartellcarter2003
02-11-2009, 12:58 AM
I have a 93 Toyota Pickup that has water dripping from the manifold where the exhaust is bolted to it. This is a brand new motor from Engine World. I just finished installing it and when I started it for the first time, the water started dripping from the bolts on the manifold where the exhaust connects. Any suggestions?

I was thinking condensation from the cold wheather here but, I am not sure.

Add your comment to this topic!