93 jimmy egr w 4.3


troubles789
10-21-2004, 01:53 PM
I have read about all the problems with the egr valve and the cpi on this site. I am having problems of rough idle and missing at idle. Take off is sluggish with the miss. There is no engine warning lights on at this time. Highway speeds not bad and passing is fine. I was wondering about the egr first, I was going to take it off and clean it for carbon. What I am wondering is, has anyone just blocked off the egr with the gasket and metal plate, like we used to in the 80's? Just leaving the egr off. If so how did it run without the darn egr. I want to know cause i am thinking of trying this.

troubles789
10-23-2004, 07:26 AM
Ok the egr cleaning didnt fix it, wasnt all that bad. Still have missing at idle and miss at takeoff and overdrive gear on highway. How do i check the cpi? I see 2 torx bolts on vortec cover. Then what?

BlazerLT
10-23-2004, 03:58 PM
Was there a pintle blocking one of the holes in the valve?

troubles789
10-25-2004, 04:22 PM
I dont know what a pintle is. I seen the 2 bigger holes on the egr with one having the plunger that went in and out. Where do I look for this and what does it do? It look like the gasket covered any smaller holes on the intake. Thanks.

BlazerLT
10-25-2004, 06:55 PM
Pintle=plunger

Have you removed the EGR valve yet?

troubles789
10-25-2004, 08:09 PM
Yep took it off and cleaned it. Not much carbon was built up. The pintle=plunger was sticking, so I soaked it and worked it till it was working freely. Put back on and the problem was still there. How do I check the cpi under the vortec top for leaks?

troubles789
10-25-2004, 08:11 PM
Yes it was stuck in one of the holes when I took it off. Just to answer your other question, I missed to tell you on.

BlazerLT
10-25-2004, 08:29 PM
Go in the blazer forum and do a search for cpi injector.

troubles789
10-25-2004, 09:00 PM
Thanks, For help.

troubles789
10-27-2004, 07:27 PM
BlazerLT I pulled the vortec top and then the center flapper that fits into the center of the top of the intake. Using a flashlight I could see a goldish tinge on the lower intake on the passanger side back only. Last back cyc side only. What do you think? cpi reg leak or what?

BlazerLT
10-27-2004, 07:50 PM
More than likely.

If there is no leaks it should be really dirty and grimey.

JackDaniels386
10-29-2004, 01:09 PM
dude, you dont want to block the egr valve, its supposed to be used to cool, and will run even worse if you block it off. Theres this thing that Tomco sells like a screen thing for it. look it up www.tomco-inc.com

BlazerLT
10-29-2004, 03:04 PM
You also do not want to use the screen.

Blocking the Carbon inside your engine is poor thinking.

You want to get the carbon out, not trap it in there.

JackDaniels386
10-30-2004, 10:13 AM
the carbon just gets burned off or broken down in there, even without the Tomco Klean screen you get a bunch of carbon stuck in there. It just burns it off. I've had mine for about a year and its been running awesome. I do take the thing out every once and a while and clean the screen. But if you dont want to do that, the GM dealers have a thing now where they reprogram some stuff in the computer, they call it an "EGR Fix" for it thats supposed to help make it better, but I dont know much about it.

BlazerLT
10-30-2004, 03:06 PM
The EGR cycle fix is all you need.

It just opens up the EGR pintle all the way sometimes to clear any chunks of carbon.

troubles789
05-23-2005, 05:03 PM
Forgot to give you the update on this. I went the ebay route and bought a acdelco cpi with shipping for a total of $153. Had in hand from Fl in 2 days. Took less then a hour to replace. Dang runs just like it did when new again. Blazerlt I used your post from s10fourms and s-series and everything worked so easy. Thanks for the detailed photos too. Also my egr ports were clean as can be, figured they might look like your pits but I got lucky. Thanks.

BlazerLT
05-24-2005, 10:41 PM
Glad to hear all is well.

Did you replace the nut kit?

Did you clean the plugged EGR port?

Did you use a new plenum gasket?

troubles789
05-25-2005, 01:32 PM
Yes,no,Yes. My egr port was perfect. Nothing to clean out,no carbon build up, go figure. Lucky I guess.

troubles789
05-25-2005, 01:35 PM
A new acdelco t-nut kit is $55 total price, shipping included, Ebay route. Advaced auto upper gasket $12.

troubles789
05-28-2005, 07:30 PM
Right here gmc95. Links to stuff should still be here from blazerlt.

Add your comment to this topic!