2001 Pontiac Grand Prix transmission problems


Ventura77
09-27-2004, 02:07 PM
To anyone who can give me a heads up. My 2001 GP SE has been giving me some tranny problems over the last couple of months. It is a strange issue, it shifts fine when it is cold, but after it warms up generally with city driving (starting and stopping), it will jerk when shifting between gears. You can also hear a whining in the transmission when it starts to jerk. I had the transmission oil and filter changed, and the guy at the shop told me that it was tripping the computer with a code that stated "too long in the shift" so he told me that what was happening is because it was taking too long with the shift that is was boosting the pressure in the system to help it shift faster. We took the filter apart on it to see if there was a significant amount of debris in it, but it looked like it was just normal wear, there were only two pieces of brass material that were a little larger in size (~3mm), but nothing to get excited about. The rest of the material was just very small specks of brass. The car has about 62,000 miles on it. Do you think it is just a solenoid that helps on the up shift, and after it is getting warm, it isn't functioning properly? I don't think that it is anything too serious, the car runs fine at highway speeds even after the jerking begins, it doens't make a difference in the gas mileage at all. If it is one of the solenoids, are they hard to put in, and how much do they cost? Thanks for your help in advance!

talia713
09-27-2004, 04:08 PM
I have a 2001 Grand Prix SE as well and I have had nothing but problems with this car. I got it used from my uncle, who is a car dealer, and it had 13,000 problems on it. At 35,000 the engine went. I noticed a knocking in the engine the got louder and louder as time went on. I had the engine replaced! At 37,000 miles my car starts shifting hard. Each gear would shift real hard. So I call up the Pontiac dealer again, and I bring it in. They hook it up to the computer and I guess there were a few bad sensors causing the hard shifting. They told me to drive it like that, and I did. About a week later, I get in my car, start it up, put it in drive, hit the gas and go nowhere!! My tranny died. I had it towed, and they had to replace a lot of sensors and do some work on my tranny. Now, my check engine light is on again. Now they think there is a short in my computer.....
This car has been a complete nightmare...I hope your car doesn't follow in the footsteps of my car.

tkhilliard
09-27-2004, 05:03 PM
maybe its a vavle thats hanging up, just an idea. i have a 02 gt that did something like that

Add your comment to this topic!