Front End Popping noise when going over bumps


BlazerLT
09-23-2004, 01:08 PM
I have practically changed my whole front suspension and it still pops in the right front end when I go over bumps.

Anyone have the same problem and had it fixed?

Mikado14
09-23-2004, 09:04 PM
Hey BlazerLT how you doin'?

You're a pretty savvy guy and your stumped??? LOL

You ain't gonna like this but about a month ago, we had a '95 come in the shop with a noise. Pop would be a good description maybe even a click like a soda can.

On the right side, a little behind where the upper control arm attaches and at the bottom of the frame, there was a 1/2 inch crack.

We cut a plate, drilled the ends of the crack to prevent migrating and welded it up with a MIG.
No more noise.

The noise was more prevelent when making a right turn over and up, like a curb inlet or when backing up to the right.

I hope I'm wrong but it is something to look at.

Good Luck

BlazerLT
09-23-2004, 09:20 PM
This sound is kind of like a shock that is bad and it freely moving.

Only happens when I am over a certain speed.

Never happens when I am going slow.

This has stumped me for a year now. It doesn't effect the ride at all si I am going to give up till it becomes worse so I can actually find it.

Trail Blazin96
09-23-2004, 09:21 PM
I had that kind of noise, but it wasn't a cracked anything it was the front swaybar, a bolt had come loose and it kept poping when i turned, and when i hit a bump! Might check the bolts on the sway!

Rodolfo
09-27-2004, 09:24 AM
I have that same problem with mine. It sounds like some plastic cover is loose somewhere on the right-front side. I'm gonna have my shocks replaced this week and ask them if they see anything weird down there. I'm have a bad spin hub too so i think it could be responsable for the sound.

Alexxn 00 Si
09-27-2004, 09:44 AM
Hey guys guess what ? This weekend I pulled both front tires, tightened both front shocks, both upper control arm bolts, and also both lower control arms bolts. On average I was able to crank a half turn on everything. SO FAR NO MORE NOISE !!

Blazer LT give that a try....

BlazerLT
09-27-2004, 01:49 PM
Hmmmm......

Might try that too.

I also found a front sway bar busing that is loose again.

I just replaced it 200 miles ago too and it is poly. Taking them both back and installing the stock rubber ones.

Trail Blazin96
09-27-2004, 08:50 PM
so the Bolts on the Sway were loose, or were the Bushings wornout?

BlazerLT
09-28-2004, 10:19 PM
Yip, the poly sway bar bushing I installed were absolute CRAP.

They didn't hold the sway bar properly.

Swapped them out for factory rubber ones from the dealer and everything is GONE!

QUIET!!! YAAAY!

Mikado14
09-28-2004, 10:25 PM
Agreed, the poly appear to not be good, seen them fail too quickly. Stick with the original. They went for a longer ride than the poly!

BlazerLT
09-28-2004, 10:28 PM
I was told and lots of people have shown me that the poly actually wear slower than the rubber.

But the thing was that they were too small in the first place.

TRucks feels new now.

Trail Blazin96
09-29-2004, 12:55 PM
well I guess I helped the infamous BlazerLT, may not have been exactly what I thought, but it allowed you to check the bushings.

BlazerLT
09-29-2004, 01:02 PM
LOL, infamous. hehe.

Yea, the poly ones I installed were 200miles old.

Warning, everyone use stock suspension parts from the dealer.

NizZ8
10-04-2004, 02:15 PM
Good to know! I'm having the same issue (popping noise from the front right side. I'll have to take a look these solutions as well.. Thnx!

BlazerLT
10-04-2004, 02:17 PM
Man, has the front end ever tightned up.

NizZ8
10-04-2004, 02:22 PM
Great to hear BlazerLT! I'm excited to check this out later after i get home from work!

NizZ8
10-04-2004, 02:26 PM
One Q,

Sway bar = Stabilizer bar, correct?

BlazerLT
10-04-2004, 09:38 PM
Yes, front one.

BTW
10-05-2004, 11:01 AM
I just bought my daughter 1995 Blazer and its making the same noise.Im going to check all of this out.Does th e torsion bar ever loosen up and make noise?

BlazerLT
10-05-2004, 10:09 PM
The torsion bar crossmember mounts do go after a while.

cata
10-11-2004, 09:29 PM
i also have this pooping noise, had my bro stand on the front bumper and rock the heck out of the truck...apparently my torsion bushing on the right side is gone..so this is a possible solution

NizZ8
10-24-2004, 01:03 AM
The crossmember mounts looked OK for me, but the nut on the right side was GONE! Luckily the bolt was still there so i just replaced the nut and will see how everything goes.

Add your comment to this topic!