1999 Jimmy Running very rough


highprofilenyc
09-11-2004, 08:28 PM
I have a 1999 GMC Jimmy 4.3. 2 wheel drive.

My problems started when my Jimmy overheated. The car started smoking. When I got to a mechanic I was told that my water pump went. So they changed the pump and the serpentine belt. The next day it overheated again and I went to a different mechanic ( closer to home) He told me that the thermostat should have been changed when the water pump was changed. So the thermostat was changed and the overheating stopped.

Since thenmy Jimmy has been idling very rough and the "service engine soon light" came on and stayed on. I had the fuel injectors cleaned, The muffler was changed ( changed the muffler because the baffles were broken). Changed the dist cap plugs ,wires and air filter.

After this mini tune up the engine was still idling rough. When in park the idling was not that bad. But when in drive and stopped at a light the idling was worse.

I took the car to a GMC dealer to have it tested. I dont remeber the code that the computer read but it was a misfiring code. I was also told that 2 of the cylinders were running at 75 PPI and the other 4 were at 150 PPI. They changed the head to the cylinder. The Jimmy still runs rough but not as rough as before. When I pop the hood and look at the engine while it is running it still shakes bad. The only differenence after changing the head is that the "service enging soon light" goes off sometimes. But eventually comes back on.

I know this is a lot. can anyone help??

Starnsum1elsesky
12-14-2004, 10:17 PM
I also had the same problem with my 1999 Jimmy. It ended up being a bad fuel injector. If you look up the recalls on this make and model there is one recall that has to do with the fuel injector. I took my Jimmy into my mechanic who didnt tell me about the recall and replaced one of the six injectors. The truck runs fine now. With the exception of the heat not working.

BlazerLT
12-16-2004, 03:00 AM
I have a 1999 GMC Jimmy 4.3. 2 wheel drive.

My problems started when my Jimmy overheated. The car started smoking. When I got to a mechanic I was told that my water pump went. So they changed the pump and the serpentine belt. The next day it overheated again and I went to a different mechanic ( closer to home) He told me that the thermostat should have been changed when the water pump was changed. So the thermostat was changed and the overheating stopped.

Since thenmy Jimmy has been idling very rough and the "service engine soon light" came on and stayed on. I had the fuel injectors cleaned, The muffler was changed ( changed the muffler because the baffles were broken). Changed the dist cap plugs ,wires and air filter.

After this mini tune up the engine was still idling rough. When in park the idling was not that bad. But when in drive and stopped at a light the idling was worse.

I took the car to a GMC dealer to have it tested. I dont remeber the code that the computer read but it was a misfiring code. I was also told that 2 of the cylinders were running at 75 PPI and the other 4 were at 150 PPI. They changed the head to the cylinder. The Jimmy still runs rough but not as rough as before. When I pop the hood and look at the engine while it is running it still shakes bad. The only differenence after changing the head is that the "service enging soon light" goes off sometimes. But eventually comes back on.

I know this is a lot. can anyone help??

Dude, go to autozone and get the codes checked for free and cme back WITH THE EXACT CODE.

Do not just take the monkey's interpretation of what is wrong, we need the numbers to help you.

Without it, we can't help you at all.

Get the codes and then the problem can be isolated.

Add your comment to this topic!