Shifting is not smooth


Astro-Driver
09-08-2004, 09:42 PM
My 92 Astro slams from 2nd to 3rd gear on my automatic transmission when giving it gas, but if I let up on the gas just before the van shifts the shifting is smooth...It only happens when I have my foot on the gas through the whole shifting process... All other gears shift smooth..Anybody know what it could be?

Delvy
09-12-2004, 12:08 AM
i recommend u change your tranny fluid. it'll cost about 60 bucks but worth every penny. do it once every 6 months......along with tune up.

Astro-Driver
09-22-2004, 12:35 PM
thanks for answering so fast! Do they make an additive to make transmissions run smoother?

SeaBuzz
09-27-2004, 09:24 PM
Slick 50 made an additive. I used it in a 1999 jeep and it work well. They also made one for the rear-end.

CD Smalley
09-27-2004, 10:11 PM
Lubeguard for the tranny. Slick50 is still in legal trouble IIRC.

trannyman52
09-28-2004, 10:58 PM
hell!!!!! changing the oil ,,,,,,can solve a rainy day too!!!!!

Astro-Driver
09-29-2004, 08:13 PM
Lubeguard for the tranny. Slick50 is still in legal trouble IIRC.


Ok I got the lubeguard in the van but still get the hard shift from 2nd to 3rd. Its weird I think it may be a pressure issue, because like i said before if I let off the gas just before the shift, it will shift alot quieter?
I still dont know what to do. That damn machine they hooked up to my van for the tranny flush screwed up my transmission!!!

gwjohnso
10-06-2004, 11:37 AM
My 94 Astro does the same thing. Have you got a solution yet?

thing
01-08-2005, 03:00 PM
i have 121,500 mileage on '99 astro. transmission seals leaked a little, so were replaced. shifting bump may have caused it. how do i stop the tranny bump ? tighten the bands ?

RexNfx400
01-09-2005, 03:53 AM
The '92 transmission is non-electronic. Totally different animal. If your '99 has a harsh upshift or downshift? Especially at 1st to 2nd gear and back you may be in "limp mode"

The "band" is non adjustable. If it clunks a little on the 2nd to 3rd shift then "its all good" because thats just the way it is. Usually not anymore than a annoyance...

thing
01-09-2005, 04:49 AM
"limp mode" is?

RexNfx400
01-09-2005, 05:16 AM
Limp mode: This is when the vehicle goes to basically safe mode of operation(simply put). Just like a home PC.

All manufactures have different limp mode stratigies for different vehicles. On yours, it creates harsh upshifts and downshifts but usually associated with the "check engine light" flashing. This is to let you know theres a problem and it needs to be resolved. This mode creates high oil pressure inside the transmission, which you will usually only "feel" on the 1st to 2nd gear shift.

thing
01-09-2005, 12:22 PM
air bag light is always on, no other "engine light" that stays on aftyer start. anything i can do other than change the tranny fluid every other year? i only drive 2.5k miles per year.

RexNfx400
01-10-2005, 04:47 PM
Thing, when does it seem to bump? What speed, heavy or light throttle? Hot or cold?

thing
01-10-2005, 05:08 PM
cold , like when i am within the first block or 2 of driving. i try to give it less gas to cushion the bump. the seals were replaced due to damage that might have been 100k miles of the bumps.
BTW, how long do i need to warm it up?

thing
01-23-2005, 02:09 PM
cold , like when i am within the first block or 2 of driving. i try to give it less gas to cushion the bump. the seals were replaced due to damage that might have been 100k miles of the bumps.
BTW, how long do i need to warm it up?
read the Haynes manual and now i think it is the DRIVE SHAFT bolt is loose.

Add your comment to this topic!