93 Jimmy


innerclaw
09-07-2004, 01:31 PM
I have a 93 jimmy4.3 vortec. Wont start bought it ran good coming home from buying it but the next day wouldnt start. I dont know the codes to tell whats wrong but I put new spark plugs and wires on. Seems not to getting Fuel To engine.

Also I just bought a code scanner it does seem to make the service engine light come on

kpajak
09-22-2004, 12:52 AM
I had a similar problem with my 93 Jimmy, although I hadn't just bought mine. First thing that I would suggest checking is to stand back by the fuel tank. Have someone else turn the key, right before the point where it tries to start. You should hear the fuel pump come on when it primes the injectors. If you don't hear the sound, more than likely you have a bad fuel pump. The other way to tell is to spray starter fluid into the intake. The car will start and run even if the fuel pump is going bad, because it will create its own suction to pull the fuel. If you turn it off and let it sit and have the same problem starting the next time, then the fuel pump needs replaced. The pump is in the gas tank and certainly a job to leave to a professional. I hope this helps. Good luck.

Ken

innerclaw
09-28-2004, 06:15 PM
Ya it was the fuel pump it wasnt hard to drop the tank. But now radiator leaks

mjohn
10-02-2004, 09:57 AM
did you replace the fuel pump and how much did it cost...? is the radiator leaking from hoses...or the radiator itself...?

innerclaw
10-04-2004, 02:13 PM
The Fuel Pump Costed me 72 with tax the radiator leaks from hoses and i think the radiator its self It only took 3 hours to drop the tank and replace the pump i also replaced the tank also.

Add your comment to this topic!