1997 Jimmy with hesitation and a pinging sound.


kyperman
08-23-2004, 06:50 PM
I am having a problem with hesitation and pinging sound. I just had the truck in and had the spark plugs replaced and the fuel filter. This happens around 55 to 70 mph. The ping and the lurch happen at about the same time, ping about a 1/2 second before the lurch. What is this?

kyperman
08-23-2004, 07:15 PM
I have a theory, could this be a code P0300 or random misfire? If so what causes this and how is it fixed?

Teaman3
08-26-2004, 05:26 PM
The ping could be "pinking", caused by too "hot" a grade of sparkplug and/or red hot carbon deposits in the cylinders (rich mixture/burning too much oil). A lean mixture will cause pinking too.

This must be corrected immediately or you risk engine damage.

Check that the correct grade spark plugs have been fitted. Sometimes a different make but "equivalent" grade can cause this.

Sooty spark plugs indicate a rich mixture. Black glazed is oil burn. Grey/white is too lean a mixture. Tan/beige is about right.

The lurch could be a sticky autobox shift (check oil level), ignition timing fault or a mixture control problem.

Check the fault codes. Also check that nothing has come unbolted eg manifold air leaks, loose distributor, loose wiring and poor connections.

Changing the fuel filter may have allowed some dirt into the fuel line, which is now trying to be discharged through the carburettor or injectors. There could a bit that's acting like a plug at higher fuel flows. Either way a clean out is a good idea.

If this work (spark plugs, fuel filter) was done by a garage, and the problem has arisen straight after, I'd go back and complain about the shoddy workmanship.

kyperman
08-26-2004, 10:55 PM
I took it back to my mechanic, he is a good guy, I don't believe he would screw me. He took it out for a drive several times, each time checking the codes and found nothing. He did say that he noticed that when the A/C was on it would lurch a little when the A/C cycled on and off. He said that it was common.

I took it today and drove for a while with and without the air on, nothing noticed when the air is off, but when the air is on I did notice it again. I believe the ping I heard was the A/C compressor or something.

Teaman3
08-30-2004, 03:51 AM
Let's hope so. If it pings going upslope in top and gets worse/better when you press/release the gas pedal while upslope, it's fuel mixture/timing.

Add your comment to this topic!