Page updated on 10-18-2017

1989 LeSabre radio problem


ipo
07-21-2004, 11:45 PM
I have recently purchased a 1989 Buick LeSabre Custom... It's a wounderful car (knock on the wood) and I am in love with it that is why I want to make it better and fix it a little bit. I am not a mechanic, but I am sure full of enthusiasm. Here are some of the few problems I have discovered and want to fix.

1. The radio.

The radio is sure acting weird. When I hit the power button you can hear the noice in the speakers... it's jsut a buzz, the particular thing though is that the lights on the radio don't come up... you can't see the clock and pushing the buttons has no effect what so ever, the only sign of life is the noice from the speacers... My first guess is that the radio is busted, so I went to the junk yard and got the same radio, I pluged it in and... the same thing just the noice from the speakers that's it. It seams like someone played with the wires or something... maybe that could be the problem, however I would really appreciate if anyone could help me out. Thanks a lot.

buickmastermind
10-10-2004, 09:42 PM
Definaletly wiring issues. There are four connectors on the back. Three of them are similar, and one plugs in elsewhere. the one that plugs in on the other side should have either two or three wires coming from it. Make sure none of them are black, and using a test light/voltometer, check to see that the wires always have power when the car is on and the parking lights are on. That should tell you where the problem lies. Also, starting with the clip side of blue, white, and black connectors, from right to left, tell me the order of the wires :) I'll be able to help more after I get that info.

Add your comment to this topic!