98 Jimmy Ignition Lock


Chia08
07-20-2004, 11:45 AM
I searched the forum and saw a thread from last year pertaining somewhat to this issue but was curious if anyone else has had the issue and what the repair procedure was?
Bear with me as I am having to use layman's terms for lack of better vocabulary.
Its pretty simple. I park and turn the key to remove it and the ignition won't let me remove the key. I can only get the key back to the second position (position referring to the 3 clicks of an ignition: off, power and accessory/start). I basically sit there and turn the key back and forth until it is released. I tried graphite but to no avail.....any other users having/had issues with this?
Of course I don't want to take it in if I don't have to but I am afraid that it will lock on me for good one of these days....

DZNZ
07-20-2004, 12:04 PM
Hey Chia -- my friend had the same problem. Dealership wanted like 300. bucks (I think) to fix the problem. She took it to a local locksmith and he charged her 70. Not sure what the cause was -- but I know what the locksmith fixed it for her for much less.

Peace,
DZNZ

Chia08
07-20-2004, 12:48 PM
Thanks DZNZ. I will keep that open as an option.
I appreciate it.
Chia

kuhurdler
07-27-2004, 09:20 AM
I have this exact same problem on a 98 GMC jimmy. I had the lock replaced. 4 days later is started again. There is a little hole under the lock that you can take the cover off of. Inside the hole is a button that releases the key.
I had a screwdriver for the longest time sitting in my cupholder to release my keys. I finally jammed a screw up into the button. Now my key comes out 100 percent of the time.

Chia08
07-27-2004, 11:33 AM
Thanks for the reply kuhurdler. I actually found a post from last year describing this cover you talked about. Its funny that you mention the screwdriver in the cupholder because that is what I am doing now. Although since the first time I depressed the brass button under the steering column it hasn't happened all that much anymore. I just left the cover to the button off and it seems to be doing much better now. If it does get stuck it is only for a few seconds then it comes right out.....weird problem.
I think until my key actaully gets stuck and won't come out I am going to keep pressing that little button!

Frainbolt
08-29-2004, 12:07 AM
After reading your post. I have the same igniton problem with my 1998 Jimmy. Mine is getting reley bad, holds key for 10 - 30 minits sometimes. If I foget key over night it runs battery down (dead). Took to our Dealer in town cost me $70.00, they said everything checked OK. So much for there knowledge on the subject. Is there a fix for this?

Chia08
08-29-2004, 11:51 AM
Frianbolt,
The only fix I have found is to remove the little plug cover on the underside of the ignition and use a screw driver to hit the release button. It will come right out. I actually keep the screw driver in my center console. I think if you leave the plug out that helps too...mine doesn't do it nearly as much.
Good Luck.
Chia

MDT1955
10-09-2004, 08:27 PM
:banghead: Not only did I have this problem, but the fuel pump kept pressure to the fuel rail running every 20-30 sec. causing battery to run down, And also
#1.) Gauges jumping off and on then going completely dead...except
for Oil pressure and Ampmeter gauges.
#2.) When putting transmission into drive, transmission slips on takeoff
in 3rd gear. In other words NO LOW (1st), 2nd, or overdrive. All
you have is 3rd (drive) !! Will manually downshift to 2nd, that's all.
Check engine light is constantly on....the code # meaning?
"Transmission is in Safe Mode". After 1 year, it has cleared up on
it's own. Did I drive it like this for 1 year? YES I DID.
#3.) Windshield wipers refusing to work and when they do, do not stop
at the base of the windshield.
#4.) Headlights refusing to work with or without Daylight switch.
#5.) Interior dome lights sometimes refuse to go off with timer or
manually.
#6.) Interior lights sometimes refuse to come on.
#7.) Heater and AC alternate hot and cold air every 15 seconds no
matter where the controller is set. (computer climate control).

A friend finally traded his after dealer replaced ignition switch 3 times.
Twice AFTER warranty was out at 36,000 miles. I believe ALL my problems are with the computer....G.M. moved a plant for the wiring harness to Mexico in late '97 I believe. I AM a G.M. employee in Indy.

Any clues or simular problems?

Add your comment to this topic!