Page updated on 12-11-2017

97' fuel gauge problem


Endofcock
07-07-2004, 09:13 PM
3.8L CS, I ran the car on close to empty for a while and then I filled it up about half tank, once it got to 1/4 tank it stopped going down any more. Now it almost treats the 1/4 mark like it's empty, it reads just fine anything above that, almost like it's just bumped up and confused.

However, I'm not sure where exactly the empty mark is and it makes me uneasy when driving. Is there any way to reset the guage considering the fact that it's reading fine?

Glad I found this forum and from what I was reading, most people get help. I'm glad to join it, thanks.

~Russell

beeaatch
10-08-2004, 11:19 PM
fuel tank level sensors sometimes get corrosive deposits on them that give erratic readings

3echo9
10-09-2004, 09:05 AM
I have the same problem on my 92. I make sure to reset my trip odometer and fill up at 250 miles. It would be nice to get it fixed but I believe that would involve dropping the tank and if that's true I'm not sure it's worth the aggrevation.

buickmastermind
10-09-2004, 08:33 PM
Okay. want it fixed? gotta drop the gas tank down, pull the fuel pump assembly out, and check to make sure the sensor is properly seated, and that the contacts are not worn. If they are worn/broken, its easier to replace than to repare. If you're lazy, and don't want to do that, fill the tank every 300-350 miles, depending on the size. 18 gal (most have this) every 300, 25 gal (most dont...)every 350 miles. That will leave you with about 3 gallons of gas left :)

buickmastermind
10-09-2004, 08:34 PM
"fuel tank level sensors sometimes get corrosive deposits on them that give erratic readings".

?????????????????????????????????????????????????? ?????????????????????????????????????????????????? ??????????????????????????????????????????????????
Do you know what gasoline is?

Add your comment to this topic!