ABS warning light


ROW
07-05-2004, 11:19 PM
I brought in my Jimmy to check my service 4wd light. I knew what I was in for regarding the motor encoder that needed to be replaced and decided to hold off on the replacement$$$. There was no other problem with the vehicle other than I can't change to 4wd. After picking up the car from the dealer and driving for a bit, the ABS warning light came on and the car would not accelerate. The engine would just rev as it reached a top speed of 30-35km/hr. I also noticed, the speedometer was no longer working. Restarting the car seems to reset abs warning light and the speedometer, but once the car starts moving and reaches 30-35km/hr, the abs light would come on. I brought the car back to the dealer and the technician reset the fault code. Worked fine till I got home. Needing to go somewhere, the problem came back as I drove the car. Is there a computer problem? There's 94000km on the car. Would anyone know or have had a similar experience and what the solution was.
Thanks
Frustrated GMC jimmy owner!

GMCTech
07-06-2004, 05:58 AM
You have a vehicle speed sensor problem.

They may have inadvertently unplugged it to do some diagnostics, or you have a bad sensor.

Check connections first. The VSS is towards the rear of the transfer case just forward of the driveshaft output by a couple inches.

Hope this helps.

ROW
07-06-2004, 04:23 PM
Driving to the dealership, it was raining and the problem went away. The dealership said that the abs fault was recorded but they need the car to act up to fully diagnose the problem. One of the mechs will bring it home with the computer hooked up to it, to record any problems. I hope it will act up so that they can solve the problem. I don't want to pay more money with nothing being done to fix it. I have to travel in the next few weeks and it is disconserting when my car is unreliable!

Add your comment to this topic!