95 Blazer-4.3 L Vortec-Low Oil Pressure


The_Revernd
07-01-2004, 03:54 PM
I have a 95 Blazer w/ 141K miles...recently (Last Weekend-June 26th) changed out Water Pump, and Thermostat to cure overheating issue (Lots of Rust during drain and flush on coolant system)...at 130K I had Full blown Tune up done...Plugs, Wires, Cap & Rotor, Oil Change, Oil Filter, Fuel Filter, air filter and cpl other minor things...after 450 dollar tune up at a Mechanic, I noticed that my Oil Pressure was fluctuating alot between 20-60+, where before the tune up it was 40+ steadily.

10K miles later (I know too long for Oil Change but LIFE has other issues) Im driving to work, Engine is now at Normal Operating temp and I stop for a light and the CHECK GUAGES Light flashes and I see my Oil Pressure has dropped to ZERO...my heart dropped along with it...The pressure came back up to around 20...When my RPM's are up above Idle the pressure is steady 40+ but as soon as it idles it drops back to 20 or less...

I have no Oil Loss or Leaks. Could this simply be due to the fact I had the overheating problem that I was using the Oil to cool the engine with and now, after 10K without an oil change, and the Overheating problem, that my Oil is so Sludged now that it is cuasing the problem??

I am at work now and dreading the fact that I have a 30 Mile trip home.. with TX heat..and Houston Traffic...before I can attempt to change the oil and see if that helps. Any suggestions appriciated!!!

Alexxn 00 Si
07-01-2004, 06:17 PM
10K miles is waaaay too long for an oil change...especially with high miles IMO.....from what I've read before these are the minimum oil pressuse readings:

6.0 psig at 1,000 engine rpm

18.0 psig at 2,000 engine rpm

24.0 psig at 4,000 enigne rpm

If when you are driving the pressure goes within these specs I wouldn't worry about driving it home and change the oil ASAP.

Also I wouldn't put too much faith in the stock oil pressure gauge....the sender and or gauge could be going bad. If you truly had no oil pressure you would hear your lifters making noise, etc.

Good luck !

The_Revernd
07-02-2004, 09:34 AM
Yes....I know 10K is EXTREME....unfortunately LIFE had other plans for me and Basically it slipped my mind that it had been that long since I changed the Oil...but enough about excuses...Sheet Happens...

I changed the Oil at work before the trek home to avoid the Stop and Go Traffic for 30 miles and let the traffic die out...I added a Quart of Oil Flush to it before the change...Replaced filter and refilled oil using 5w-30...Oil Pressure is steady between 20-40 now...This morning when I started engine, the pressure was just reaching 50+...so nominal stats from what I see...

Thankx for the info on the Min. psi ...Hopefully it was as simple as an oil change...I guess If we see this post again resurface you will know :)

drewgibs
07-03-2004, 07:49 PM
I read somewhere (I think alldatadiy.com) that min oil pressure was 42psi at 1000rpm, my oil pressure fluxuates a lot too, mostly when its idle the needle will bounce around really fast, I was told my oil pressure sensor switch is going bad, I havn't had a chance to change it yet so I can't tell you if that will fix the problem or not but I suspect it will.

rlith
07-04-2004, 04:25 PM
Before panicking I would at this point just change the oil pressure sender, it's only about 15 bux...Those are typically what go bad, not the oil pump...

tomminajar
07-05-2004, 12:58 AM
What weight oil did you have put in ? Also it (oil) doesn't smell like gas - Does it?

Add your comment to this topic!