error code p0171


chuckydt
04-08-2004, 02:08 AM
I have a 97 altima and my check engine light keeps coming on, i had a diagnostic ran and it said p0171 system is running lean bank 1. After checking with the nissan dealer i changed both 02 sensors and had the code cleared, the problem came back with the same error code. Now they are saying that its the intake manifold gasket which is sucking in air, which is about $950. I got a second opinion from another mechenic and he says that couldn't be the problem because my car is not hesitating. I get poor gas mileage and the CEL keeps coming on and going off. I also noticed that my atifreeze is leaking a bit from a hose below the distributor cap, can anyone give me some input?

Thanks DCT

sleeperalty
04-12-2004, 09:11 PM
the code is definately the O2 sensor code. and that one is the rear O2 code after the Cat. Your timing might be messed up and that is causing you to kill your O2 sensors

habenero2002
06-24-2004, 09:53 PM
i have seen mass airflow meters cause this problem. Low fuel pressure. Intake leaks. Air leaks between the MAF and intake manifold. exhaust leaks before the o2 and the o2 itself

jnwings
11-20-2005, 07:39 PM
Mine was caused by a simple hole on the boot of the pvc valve...i had the code for bank 1 and 2

FixUrNissan
11-20-2005, 11:42 PM
I have a 97 altima and my check engine light keeps coming on, i had a diagnostic ran and it said p0171 system is running lean bank 1. After checking with the nissan dealer i changed both 02 sensors and had the code cleared, the problem came back with the same error code. Now they are saying that its the intake manifold gasket which is sucking in air, which is about $950. I got a second opinion from another mechenic and he says that couldn't be the problem because my car is not hesitating. I get poor gas mileage and the CEL keeps coming on and going off. I also noticed that my atifreeze is leaking a bit from a hose below the distributor cap, can anyone give me some input?

Thanks DCT

Ok this may be costly but this is probabbly your problem. MAF ( Mass Air Flow Meter ) If you can get someone with a scanner to check your cars Alfa Readings.. It should be around 100% chances are your running 80% witch is lean . the reason is most likly your MAF is not metering Air properly.When this happens you can get codes like that . I would start there. Knowing Nissans the way i do

RAREROD74
12-05-2005, 12:56 AM
I have a 97 altima and my check engine light keeps coming on, i had a diagnostic ran and it said p0171 system is running lean bank 1. After checking with the nissan dealer i changed both 02 sensors and had the code cleared, the problem came back with the same error code. Now they are saying that its the intake manifold gasket which is sucking in air, which is about $950. I got a second opinion from another mechenic and he says that couldn't be the problem because my car is not hesitating. I get poor gas mileage and the CEL keeps coming on and going off. I also noticed that my atifreeze is leaking a bit from a hose below the distributor cap, can anyone give me some input?

Thanks DCT
the intake is a common issue on 2.4 altimas p0171 and o2 sensor bad HUH the o2 sensor did its job It told the ecm of the lean condition . the ecm tried to compensate the by leaning the mixture but because the unmonitored air is entering due to the intake leak multiple failures caused the cel to be illuminated . I work for a nissan dealer and I such a misdiagnosis shouldnt have happend . also the hose under the is it large diameter of small ???..

sethstyle16
12-05-2005, 11:38 PM
Mine was caused by a simple hole on the boot of the pvc valve...i had the code for bank 1 and 2

mine was caused by a pinhole in the pipe about 2 inches past the cat.

x1gary
01-03-2006, 11:48 PM
Im having the same problem P0171 ... I recently installed bothe O2 Sensors. The car seems to run fine, but i looked at the spark plugs, and it is indeed running lean .... any other solutions ?

-G-

Handyman2005
04-20-2008, 04:31 PM
Well I just learned something from this post. I have a small hole, about 1/4 inch right next tp the reap O2 sensor. I was going to psot a question about my '95 Altima running lean AND hot......Maybe I will get some of that muffler epoxy and close that hole up and see what happens....If anyone has any comments about other reasons why these engines tend to run lean, please contact me,,,,,Thanks

JoeShmoe
04-21-2008, 11:57 AM
I know FixUrNissan knows what he's talking about. I would check your MAF sensor and pcv valve. Then your whole exhaust system for leaks. Is your car better Handy?

Add your comment to this topic!