Engine problems - Car sputters & lights dim while accelerating


co2-dioxide
03-08-2004, 09:41 PM
My 1994 Geo Metro sputters and jerks when I accelerate. Also, the headlights dim really low and I seem to loose power. When I let off the gas pedal and pump it several times, the car regains power and the headlights brighten back up.

I had the battery and alternator checked and they are both in excellent condition. What could be causing this problem?

geozukigti
03-09-2004, 02:06 PM
seems more like a really bad ignition issue. Change your cap and rotor ($12), and spark plugs. If you want to, also change your wires. Could also be a leaky injector. Either way, something is causing your car to not fire properly. Check your ignition timing with a timing light. Worst case scenario... Your timing key at the crank that holds the timing belt gear in alignment is sheered off, and your timing is varying on you while you drive.

co2-dioxide
03-09-2004, 03:33 PM
Thank you for the info. I'll give that a try and let you know what happens. I really appreciate it =)

neves
03-13-2004, 07:42 PM
metros are also tempermental to sputtering and seeming to have ignition problems because of a work timing belt. it may appear to be not worn, but if it has streatched enough to ofset the cam by 3 degrees, then you will have engine problms simmilar to what you are describing.

kingmt
04-09-2004, 12:37 AM
I would do a compristion test befor putting much money in it you may have to pull the head.

Add your comment to this topic!